cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
beckman
Visitor
Visitor
4,109 Views
Registered: ‎12-04-2013

XSCT tcl script fails, but runs fine when entered manually

Jump to solution

I'm trying to use a tcl script so I can automate the build process.  When I run the script using xsct it produces the error shown below.  If I launch xsct and run the commands manually, it seems to work fine.  Ay ideas what I'm missing here?  In this copied text below I first display the script using tail.  Then I try to execute the script by running "xsct Scripts/sdk.tcl"  The unexpected argument errors are then shown.  I then launch xsct and manually enter the same commands and it seems to work fine.

 

beckman@ubuntu-83a:~/fpgadev/FPGA-Phase2$ tail Scripts/sdk.tcl
setws sdk
createhw –name hw0 -hwspec sdk/HW_Platform/PlatformBlockDiagram_wrapper.hdf
### createbsp -name bsp0 -proc ps7_cortexa9_0 -hwproject hw0 -os standalone
### createapp -name fsbl0 -app {Zynq FSBL} -proc ps7_cortexa9_0 -hwproject hw0 -bsp bsp0 -os standalone
projects –build
exit
beckman@ubuntu-83a:~/fpgadev/FPGA-Phase2$ xsct Scripts/sdk.tcl
unexpected arguments: –name hw0 -hwspec sdk/HW_Platform/PlatformBlockDiagram_wrapper.hdf
while executing
"error "unexpected arguments: $arglist""
(procedure "::xsdb::get_options" line 69)
invoked from within
"::xsdb::get_options args $options"
(procedure "createhw" line 10)
invoked from within
"createhw –name hw0 -hwspec sdk/HW_Platform/PlatformBlockDiagram_wrapper.hdf"
(file "Scripts/sdk.tcl" line 2)
beckman@ubuntu-83a:~/fpgadev/FPGA-Phase2$ xsct

****** Xilinx Software Commandline Tool (XSCT) v2017.1
**** Build date : Apr 14 2017-19:01:58
** Copyright 1986-2017 Xilinx, Inc. All Rights Reserved.


xsct% setws sdk
xsct% createhw -name hw0 -hwspec sdk/HW_Platform/PlatformBlockDiagram_wrapper.hdf
Starting xsdk. This could take few seconds... done
xsct% exit
exit
beckman@ubuntu-83a:~/fpgadev/FPGA-Phase2$

0 Kudos
1 Solution

Accepted Solutions
egholm
Visitor
Visitor
6,644 Views
Registered: ‎05-13-2016

Hi Beckman,

 

The problem is that you copied the script from the internet (I just did the same :)) and got a silly dash-character instead of the real ascii one in front of "name":

createhw –name hw0 -hwspec ...

 

should read:

createhw -name hw0 -hwspec ...

 

BR,

Martin

View solution in original post

2 Replies
egholm
Visitor
Visitor
6,645 Views
Registered: ‎05-13-2016

Hi Beckman,

 

The problem is that you copied the script from the internet (I just did the same :)) and got a silly dash-character instead of the real ascii one in front of "name":

createhw –name hw0 -hwspec ...

 

should read:

createhw -name hw0 -hwspec ...

 

BR,

Martin

View solution in original post

beckman
Visitor
Visitor
3,976 Views
Registered: ‎12-04-2013

Martin:

 

Your suggestion fixed the problem.  I now have no choice but to start the Society Against Dashes, or SAD. 

 

Thanks,

 

-Bill 

 

 

 

0 Kudos