UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Adventurer
Adventurer
10,047 Views
Registered: ‎03-31-2014

error in creating IP : syncronizer_simple

Jump to solution

Hi,

I'm trying to add syncronizer_simple IP to my block diagram using the below command:

set synchronizer_simple_1 [ create_bd_cell -type ip -vlnv xilinx.com:user:synchronizer_simple:1.0 synchronizer_simple_1]

 

the tools throws following error : 

 

************************************************************************************************************************************

set synchronizer_simple_1[ create_bd_cell -type ip -vlnv xilinx.com:user:synchronizer_simple:1.0 synchronizer_simple_1]
ERROR: [BD 5-216] VLNV <xilinx.com:user:synchronizer_simple:1.0> is not supported for this version of the tools.
ERROR: [Common 17-39] 'create_bd_cell' failed due to earlier errors.

***********************************************************************************************************************************

 

Tool version used is 2014.3

 

Please help me resolve this isse.

 

Thanks,

Asan,.

0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
17,009 Views
Registered: ‎01-16-2013

Re: error in creating IP : syncronizer_simple

Jump to solution

Hello @ajasan,

 

I was able to replicate the error with the shared files:

Capture.PNG

 

The issue is because the user IP repository are not getting updated in Vivado. After setting the IP repository path

"set_property ip_repo_paths ../../sources/synchronizer_simple [current_fileset]"

 

You need to execute the following TCL command:

update_ip_catalog

 

I have attached the modified TCL file for reference.

 

 

--Syed

 

-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

-----------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
11 Replies
Xilinx Employee
Xilinx Employee
10,042 Views
Registered: ‎07-21-2014

Re: error in creating IP : syncronizer_simple

Jump to solution

Hi,

which vivado tool version are you using?
please refer following AR regarding VLNV
http://www.xilinx.com/support/answers/50478.html

You need to update the VLNV as well according to new version of tool.

thanks,
Shreyas

----------------------------------------------------------------------------------------------
Try to search answer for your issue in forums or xilinx user guides before you post a new thread.

Kindly note- Please mark the Answer as "Accept as solution" if information provided solves your query.
Give Kudos (star provided in right) to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Moderator
Moderator
10,028 Views
Registered: ‎01-16-2013

Re: error in creating IP : syncronizer_simple

Jump to solution

Hello @ajasan,

 

Check if you have added the user IP in the Repository Manager under project settings.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
10,026 Views
Registered: ‎03-31-2014

Re: error in creating IP : syncronizer_simple

Jump to solution

I'm using Vivado2014.3

 

I checked the VLNV in IP catalog it is mentioned as same. i.e, xilinx.com:user:synchronizer_simple:1.0

]

0 Kudos
Moderator
Moderator
10,023 Views
Registered: ‎01-16-2013

Re: error in creating IP : syncronizer_simple

Jump to solution

Hi @ajasan,

 

Instead of using TCL command, can you try adding the IP to block design  from Vivado GUI? I doubt this could be syntax error.

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
10,018 Views
Registered: ‎03-31-2014

Re: error in creating IP : syncronizer_simple

Jump to solution

Hi @syedz,

Yes, I can give try.

But am running a TCL script n which it enumerates synchronizer_simple IP.

 

It names the IP as "synchronizer_simple_1" and refrences it in later part of the script. (as you could see from the command I have given in my post)

 

In that case, if I'm generating it through GUI, it names the Ip as "synchronizer_simple_0". and the tool considers the instantiations of the IP as "not found".

 

I have also observed that if I'm reapeating the command by changing the version or label , it works after sometime withotut any error but with the same command, which is very strange.

 

Please suggest what could be the possible way to solve this.

 

Thanks,

Asan.

0 Kudos
Xilinx Employee
Xilinx Employee
9,987 Views
Registered: ‎07-21-2014

Re: error in creating IP : syncronizer_simple

Jump to solution
Hi,
Are you using command write_bd_tcl to generate the tcl script?
can you share the tcl script?

Thanks,
Shreyas
----------------------------------------------------------------------------------------------
Try to search answer for your issue in forums or xilinx user guides before you post a new thread.

Kindly note- Please mark the Answer as "Accept as solution" if information provided solves your query.
Give Kudos (star provided in right) to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
9,983 Views
Registered: ‎03-31-2014

Re: error in creating IP : syncronizer_simple

Jump to solution

@aher,

 

I'm trying to generate a reference design's project.

Script is generated in 2013.3 and I'm using 2014.3

 

1. Run zynq_rc_x4g1_ed.tcl till 7th line, by manually Copy + Paste - ing it into the TCL console

2. Run x4g1_bd.tcl by commenting the intial lies which checks for the version and also changing the version of IP's according to the tool's recommned version.

3. Error occurs in synchronizer_simple IP creation command.

 

Please find the unaltered tcl script also, as such given with the refrence design, named as ""

 

Thanks.

0 Kudos
Moderator
Moderator
9,963 Views
Registered: ‎01-16-2013

Re: error in creating IP : syncronizer_simple

Jump to solution

Hello @ajasan,

 

You have set the synchronizer_simple IP in User_repository. Can share this complete folder "synchronizer_simple" and also zynq_rc_x4g1_top.v file?

 

--Syed

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
9,934 Views
Registered: ‎03-31-2014

Re: error in creating IP : syncronizer_simple

Jump to solution

@syedz,

Please find the files attached.

0 Kudos
Moderator
Moderator
17,010 Views
Registered: ‎01-16-2013

Re: error in creating IP : syncronizer_simple

Jump to solution

Hello @ajasan,

 

I was able to replicate the error with the shared files:

Capture.PNG

 

The issue is because the user IP repository are not getting updated in Vivado. After setting the IP repository path

"set_property ip_repo_paths ../../sources/synchronizer_simple [current_fileset]"

 

You need to execute the following TCL command:

update_ip_catalog

 

I have attached the modified TCL file for reference.

 

 

--Syed

 

-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.

-----------------------------------------------------------------------------------------------

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.

Did you check our new quick reference timing closure guide (UG1292)?
---------------------------------------------------------------------------------------------
0 Kudos
Adventurer
Adventurer
7,870 Views
Registered: ‎03-31-2014

Re: error in creating IP : syncronizer_simple

Jump to solution

@syedz, Thanks for the prompt reponse.

 

The error is resolved

 

Asan.

0 Kudos