取消
显示结果 
显示  仅  | 搜索替代 
您的意思是: 
Highlighted
Visitor
Visitor
410 次查看
注册日期: ‎06-01-2020

下载器连接问题

跳至解决方案

使用环境为vivado 2018.2,使用器件为7z100,打开hardware manager,无法连接器件。错误提示为labtools 27-2269.

提示为未发现目标设备,检查电缆是否连接好,目标板是否加电。

使用下载器为HW-USB-II-G,在设备管理器中能看到下载电缆。

板子上JTAG接口供电已经测量过,可正常供电,2腿有3.3V供电。另外在印制板上已将BOOT管脚设置为JTAG方式。

另外,使用ISE自带的impact连接,可看到有多个设备。

求解为何vivdo无法连接设备?

0 项奖励
1 解答

已接受的解答
Highlighted
Visitor
Visitor
178 次查看
注册日期: ‎06-01-2020

感谢大家。差不多折腾了一个星期,问题已经解决了。

JTAG 接口的TDI 和TDO 的管脚由于参考其他公司的原理图,对地加了0.1u 的电容。电容解焊后就能正常连接仿真器了。

再次感谢大家

在原帖中查看解决方案

0 项奖励
6 回复数
Highlighted
Explorer
Explorer
383 次查看
注册日期: ‎12-28-2018

你是不是把ISE和vivado同时开打着的?你把ISE的工程全部关闭,然后电脑重启就可以了,你试试

Highlighted
Visitor
Visitor
379 次查看
注册日期: ‎06-01-2020

没有,我是因为vivado连接不上,所以才换了一个有ISE 的电脑。是在两个不同的电脑上,所以不存在同时开着的问题

0 项奖励
Highlighted
Explorer
Explorer
369 次查看
注册日期: ‎12-28-2018

我遇到几个情况是连接不上,

一个就是ISE同时打开,,

一个是同一个工程选择了不同器件连接板子上一个仿真器识别错误,就会报错,

一个是vivado造成的,就是没打开ISE,也没器件,就是连不上,只要断电重启电脑,就好了,感觉是bug。

一个就是你打开2016版本的,也打开2018版本的话,只要你连接其中一个版本,你再去连接其他版本,仿真器也是连不上。也就说不同版本的vivado同时打开也会报错。

一个是劣质仿真器,之前遇到过很差的仿真器,识别不了器件,换一个好一点的就可以了。上述是我遇到的问题,不知道你遇到的是什么样的,如果解决了,欢迎分享

Highlighted
Xilinx Employee
Xilinx Employee
362 次查看
注册日期: ‎06-02-2017

@xiaojie 你好,

相同环境下换一块FPGA板块可以正常检测吗?比如官方的开发板?从描述来看不排除电路板的问题,所以可以先排除这方面因素

-------------------------------------------------------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
--------------------------------------------------------------------------------------------------------------------------------------------
Highlighted
Visitor
Visitor
332 次查看
注册日期: ‎06-01-2020

换了开发板vivado 可以正常连接。

JTAG 接口电路,BOOT 管脚电路接法见图片。BOOT 管脚目前3脚和4脚短接,为JTAG 模式。

ISE IMPACT 连接见图片。

示波器测量波形,黄色为3.3V 供电,为给IO BANK 供电的电源,蓝色为POR _B ,紫色为SRST _B 。是否跟上电顺序有关?

 

mmexport1591066270217.jpg
mmexport1591066268630.jpg
mmexport1591066266907.jpg
mmexport1591066264900.jpg
0 项奖励
Highlighted
Visitor
Visitor
179 次查看
注册日期: ‎06-01-2020

感谢大家。差不多折腾了一个星期,问题已经解决了。

JTAG 接口的TDI 和TDO 的管脚由于参考其他公司的原理图,对地加了0.1u 的电容。电容解焊后就能正常连接仿真器了。

再次感谢大家

在原帖中查看解决方案

0 项奖励