UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

取消
显示结果 
搜索替代 
您的意思是: 
Adventurer
Adventurer
486 次查看
注册日期: ‎05-03-2018

Vivado_debug时看不见已经添加的信号线

在通过Vivado进行在线调试的时候,在BD中添加了debug的信号(小乌龟),但是在set up debug时,却看不见已经添加的信号线

 

1544690769(1).png1544690769.png

0 项奖励
4 条回复4
Community Manager
Community Manager
467 次查看
注册日期: ‎08-30-2011

回复: Vivado_debug时看不见已经添加的信号线


@shiyangcool  已写:

在通过Vivado进行在线调试的时候,在BD中添加了debug的信号(小乌龟),但是在set up debug时,却看不见已经添加的信号线

 

1544690769(1).png1544690769.png


@shiyangcool

你在mark了debug以后,有没有做run connection automation,添加system ila?

-------------------------------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------------------------------
如果提供的信息能解决您的问题,请标记为“接受为解决方案”。
如果您认为帖子有帮助,请点击“奖励”。谢谢!
-------------------------------------------------------------------------------------------------
0 项奖励
Adventurer
Adventurer
457 次查看
注册日期: ‎05-03-2018

回复: Vivado_debug时看不见已经添加的信号线

应该不是run connection automation的问题,run完以后还是没有,而且左边图片里已有的信号线,之前没有run connection automation,也看得见,后来添加debug管脚后,就看不见新添加的了
0 项奖励
Adventurer
Adventurer
450 次查看
注册日期: ‎05-03-2018

回复: Vivado_debug时看不见已经添加的信号线

0 项奖励
Xilinx Employee
Xilinx Employee
377 次查看
注册日期: ‎05-14-2008

回复: Vivado_debug时看不见已经添加的信号线

看不见的这些信号,看起来像顶层管脚信号,对吗?

如果是顶层管脚信号,mark_debug加在跟pad直接相连的net上是不行的,因为这些net是PAD内部的线,无法连接到ILA。只有经过IBUF后的net才可以连接到ILA

-vivian

0 项奖励