UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

取消
显示结果 
搜索替代 
您的意思是: 
Highlighted
Visitor liumeiyan
Visitor
184 次查看
注册日期: ‎03-28-2019

vivado2018.2 上运行lwip echo server例程出现报错,以及怎么安装补丁文件

转到解答

Xilinx开发环境: vivado 2018.2

运行环境: window10 64位

我在vivado 2018.2中创建了block design——> launch到SDK中 ——> 创建lwip echo server例程 ——>SDK自动bulid Apllication。此时就出现了以下报错:

无标题.jpg

在论坛上搜了一下,发现有可能是vivado2018.2的版本问题,官网提供了.patch文件,说是安装补丁文件即可。 (AR#71330 详见:https://china.xilinx.com/support/answers/71330.html

可是我无法成功安装patch文件!把论坛上相关帖子都看了一遍,也没找对方法(主要参考了AR#53821 https://china.xilinx.com/support/answers/53821.html

被卡在这里一天了T_T,请大家帮忙看看,在线等,谢谢!

标记 (1)
0 项奖励
1 个已接受解答

已接受的解答
Xilinx Employee
Xilinx Employee
163 次查看
注册日期: ‎02-28-2019

回复: vivado2018.2 上运行lwip echo server例程出现报错,以及怎么安装补丁文件

转到解答

Hi @liumeiyan ,

这个和一般的加patch不同,按照patch里面描述的,把代码加到相应的文件(xadapter.c)即可。

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
2 条回复2
Xilinx Employee
Xilinx Employee
164 次查看
注册日期: ‎02-28-2019

回复: vivado2018.2 上运行lwip echo server例程出现报错,以及怎么安装补丁文件

转到解答

Hi @liumeiyan ,

这个和一般的加patch不同,按照patch里面描述的,把代码加到相应的文件(xadapter.c)即可。

-------------------------------------------------------------------------
Don't forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
Visitor liumeiyan
Visitor
135 次查看
注册日期: ‎03-28-2019

回复: vivado2018.2 上运行lwip echo server例程出现报错,以及怎么安装补丁文件

转到解答

非常感谢! 问题解决了,把patch文件中的代码加到xadapter.c中后,就没有报错了。

我把修改后的xadapter.c文件贴上来了,遇到同样问题的同学可以参考下。

0 项奖励