UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor sameedsohail
Visitor
4,935 Views
Registered: ‎07-16-2014

AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

Hi,

 

I am using an AC701 Evaluation kit for implementing UDP transmission using Vivado 2014.2. The kit was been working fine.

 

But in the past few days, the FPGA in the kit is getting heated up when un-programmed & powered ON. As can be confirmed by physically touching the FPGA. But the temperature reading given by IMPACT is within safe operating range (37 C as shown in Screenshot). The issue first arose when i tried to reprogram the FPGA via IMPACT after closing the HW manager in Vivado 2014.2. The JTAG cable was not being found by IMPACT(although it was connected & not being used by any other program) & the FPGA started heating up.

 

When i program the FPGA, the temperature goes down and the FPGA operates normally. But when i reset or power on the device again, the FPGA starts heating up.

 

Kindly provide any tips on solving this issue.

 

Thank you.

 

Regards,

temp_reading.png
0 Kudos
1 Solution

Accepted Solutions
Moderator
Moderator
6,618 Views
Registered: ‎01-15-2008

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

you can change the mode settings to jtag or erase the spi flash contents and check if the fpga is still becoming hot when powered on.

 

--Krishna

View solution in original post

12 Replies
Moderator
Moderator
4,932 Views
Registered: ‎01-15-2008

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

what is the mode pin settings?

can you check if the fpga is configured from the flash when powered on.

 

--Kirshna

Community Manager
Community Manager
4,919 Views
Registered: ‎07-23-2012

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution
Hi,

I faced a similar issue where the FPGA temperature goes up monotonically in chipscope analyzer. But I didn't touch the FPGA to feel the heat.

I found the reason to be Vivado HW manager being open.

When I closed the HW manager and tried to configure the device, it was successful and even in chipscope analyzer, the die temperature was constant.

Regards,
Krishna
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos
Xilinx Employee
Xilinx Employee
4,903 Views
Registered: ‎08-01-2012

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

During reprograming the FPGA, you might use new design /modified factory supplied reference design. Please note that while using new designs you should make sure that the new design should match with existing board hardware.

 

Especially the IO directions and bank voltages and IO standards should match with existing board hardware. For example if any conflict in IO directions or bank voltages mismatch may cause FPGA over heat

 

To check board health, please reconfigures board with factory supplied reference designs and test it.  

 

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

Visitor sameedsohail
Visitor
4,884 Views
Registered: ‎07-16-2014

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

@Kirshna

 

Thank you for your prompt reply.

 

Yes. I checked the setting for the Configuration mode it is using Master SPI (Quad SPI Flash U7).

 

Could this be the reason behind heating up when powered ON in this mode & being programmed using JTAG in IMPACT / Hardware Manager?

 

 

Regards,

 

Sameed 

0 Kudos
Visitor sameedsohail
Visitor
4,879 Views
Registered: ‎07-16-2014

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

@Kirshna

 

Thank you for your prompt reply.

 

When i turn ON my FPGA from when its powered OFF the temperature starts to increase & the die gets so hot that FPGA cannot be touched after some time.

 

But when the FPGA is programmed using the HW manager or the IMPACT software, i notice the temperature suddenly goes normal from HIGH.

 

Could this be because of the configuration settings (SPI Flash) on the FPGA??

 

Regards,

 

Sameed 

0 Kudos
Moderator
Moderator
6,619 Views
Registered: ‎01-15-2008

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

you can change the mode settings to jtag or erase the spi flash contents and check if the fpga is still becoming hot when powered on.

 

--Krishna

View solution in original post

Visitor sameedsohail
Visitor
4,873 Views
Registered: ‎07-16-2014

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

Hi.

 

Where can i find links for Artix 7 AC701 board default factory designs. The BaseTargetedDesigns are based on AC701 board but require additional resources.

 

As i remeber while working with Virtex 5 ML507 board i once had to reporgram or erase the internal flash. Xilinx provided a tool for Windows to perform this process but i cannot find one for AC 701 board. Please guide me if such tool exists for AC701 board. 

 

Thanks.

 

 

0 Kudos
Visitor sameedsohail
Visitor
4,869 Views
Registered: ‎07-16-2014

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

@Krishna

 

I cant seem to locate the SPI in the design in IMPACT nor i am able to program it. I dont see it listed when i initialize the chain in JTAG. I think as it is part of the chain, it should be listed in IMPACT.

 

As you can see in the screenshot i have attached.

 

I tried to create a PROM file & then program it from inside IMPACT but it is not working??? It cannot be found by Impact is what appears at the end.

 

 

Reagrds,

 

Sameed

SPI Flash.png
0 Kudos
Moderator
Moderator
4,858 Views
Registered: ‎01-15-2008

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

can you first check with mode pins set to jtag m[2:0] = "101" and see if this makes any difference.

 

--Krishna

Visitor sameedsohail
Visitor
2,315 Views
Registered: ‎07-16-2014

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

@kkn  

 

Hi, 

 

Yes, when i change my configuration settings to JTAG, the FPGA doesnt heat up i have checked it in both porgrammed & un-programmed state. Thank you for that.

 

But as my application will require boot up from SPI flash in near future, therefore it is imperative that i be able to erase the SPI FLASH from IMPACT so that it doesnt interfere with my future design.

 

I followed the http://www.xilinx.com/support/documentation/application_notes/xapp586-spi-flash.pdf tutorial provided by Xilinx step by step but couldnt erase the SPI PROM. It keeps giving me the error that the flash could not be programmed. Screenshot is attached.

 

On pg 13 of the tutorial there is mentioned under the heading "Programming SPI Flash In-System" that an interface design must be loaded in  7 Series FPGA that bridges the programming cable to SPI flash.

1) Does it mean that my designed module must have internal connections with SPI in constraints file  ?

2) Can i erase the PROM easily from IMPACT without going into the design problem mentioned above ?

3) Is this issue because of IMPACT ver or some other problem?

 

Can you please provide any insight on how to erase the SPI Prom Flash from IMPACT or Vivado.

 

The details of my design are as follows:

IMPACT 64: Lab Tools ISE 14.2

Vivado 2014.2

Artix 7 AC701 Evaluation Board

SPI  Quad PROM N25Q256A13ESF40G (256 MB - Non Volatile Memory)

 

 

Thank you.

 

Regards,

 

Sameed

error.png
0 Kudos
Moderator
Moderator
2,292 Views
Registered: ‎01-15-2008

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

can you try to use the latest impact 14.7 tool

Hope you have set the mode pins to spi mode when you to program the spi flash and configure from it.

http://www.xilinx.com/support/download/index.htm

 

--Krishna

0 Kudos
Highlighted
Visitor sameedsohail
Visitor
2,287 Views
Registered: ‎07-16-2014

Re: AC-701 FPGA getting Heat Up when Unprogrammed

Jump to solution

@kkn 

 

Thanks.

 

Found a solution to the problem at:

http://www.xilinx.com/support/answers/54139.html#masterSPI

 

By running the erase_tcl file i was able to erase the PROM successfully. Have verified the operation. 

 

Thanks.

 

 

0 Kudos