UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor sjh@notts
Visitor
5,572 Views
Registered: ‎04-22-2016

Building U-Boot for ZC706 fails on RHEL6

Jump to solution

I am trying to build u-boot so I can use the tools to create a ramdisk image for the zc706 board.

I have downloaded the git as described in the 'fetch sources' wiki pages onto my Linux RHEL6 PC.

 

Performing the 'make zynq_zc706_config' command as detailed on the 'build u-boot' wiki pages seems OK.

However, when following with the simple 'make' command I get the following error:

 

[root@SJH-LX-DT u-boot-xlnx]# make
  CHK     include/config/uboot.release
  CHK     include/generated/version_autogenerated.h
  CHK     include/generated/timestamp_autogenerated.h
  UPD     include/generated/timestamp_autogenerated.h
  CC      lib/asm-offsets.s
lib/asm-offsets.c:1: error: bad value (armv5) for -march= switch
lib/asm-offsets.c:1: error: bad value (armv5) for -mtune= switch
make[1]: *** [lib/asm-offsets.s] Error 1
make: *** [prepare0] Error 2
[root@SJH-LX-DT u-boot-xlnx]# ^C

 

I notice that the config file created (.config) uses the value armv7, is this connected?

 

I have had a look through the various posts but can't find any reference to this error

Thanks

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Participant pete_128
Participant
10,527 Views
Registered: ‎04-02-2016

Re: Building U-Boot for ZC706 fails on RHEL6

Jump to solution

Do you set the CROSS_COMPILE environment variable?

 

I have this to build u-boot myself:

 

CROSS_COMPILE=arm-none-eabi- make -j8

Where I am building with arm-none-eabi-gcc. CROSS_COMPILE should be set to a GCC (but without the gcc at the end) visible on $PATH or you can just set it to a fully qualified absolute path. Sourcing the Vivado (SDK probably works too) settings64.sh, arm-xilinx-eabi- appears on my PATH so that might be a working value for you if you have SDK installed.

View solution in original post

2 Replies
Highlighted
Participant pete_128
Participant
10,528 Views
Registered: ‎04-02-2016

Re: Building U-Boot for ZC706 fails on RHEL6

Jump to solution

Do you set the CROSS_COMPILE environment variable?

 

I have this to build u-boot myself:

 

CROSS_COMPILE=arm-none-eabi- make -j8

Where I am building with arm-none-eabi-gcc. CROSS_COMPILE should be set to a GCC (but without the gcc at the end) visible on $PATH or you can just set it to a fully qualified absolute path. Sourcing the Vivado (SDK probably works too) settings64.sh, arm-xilinx-eabi- appears on my PATH so that might be a working value for you if you have SDK installed.

View solution in original post

Visitor sjh@notts
Visitor
5,286 Views
Registered: ‎04-22-2016

Re: Building U-Boot for ZC706 fails on RHEL6

Jump to solution

thanks for that.

0 Kudos