cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Participant
Participant
3,454 Views
Registered: ‎10-17-2016

Failed to access library 'msim/xil_defaultlib' at "msim/xil_defaultlib".

Jump to solution

Hi,

When simulating the BRAM IP core utilize modelsim 10.4 and vivado 2014.3,I faced the problem-Failed to access library 'msim/xil_defaultlib' at "msim/xil_defaultlib" in simulate.log.And,in tcl console,there are only some infos but can't launch modelsim.Then how can I do with it?

Regards,

Sophia

 

0 Kudos
Reply
1 Solution

Accepted Solutions
Participant
Participant
5,983 Views
Registered: ‎10-17-2016

Hi,

The log shows'scripts have generated ,please check the console window'

The problem has been solve by unticking the 'generate scripts only' in the simulate setting.

View solution in original post

0 Kudos
Reply
2 Replies
Xilinx Employee
Xilinx Employee
3,442 Views
Registered: ‎10-24-2013

Hi @sophia_123

Did you set the modelsim executable path correctly? Also, did you compile the simulation libraries correctly?

Please post the compile_simlib log and your run log here.

Thanks,Vijay
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.
0 Kudos
Reply
Participant
Participant
5,984 Views
Registered: ‎10-17-2016

Hi,

The log shows'scripts have generated ,please check the console window'

The problem has been solve by unticking the 'generate scripts only' in the simulate setting.

View solution in original post

0 Kudos
Reply