UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant jacob.varghese
Participant
4,736 Views
Registered: ‎05-28-2015

I2C EEPROM Interface with KC705 board

Jump to solution

Hello,

I am working on I2C interface. I am use xilinx sample code "xiic_eeprom_example.c" . When I run the code it seems to loop infinitely in while loop where it is check the status register condition.

 

I came across similar problem in this link, but problem not resolved

https://forums.xilinx.com/t5/Embedded-Development-Tools/Problem-with-xiic-eeprom-example-c-Virtex-5-using-microblaze/td-p/343299

 

 

Have anyone come across with similar problem?Can anyone tell me the root for this cause?

 

 

iic.png
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
8,894 Views
Registered: ‎08-01-2008

Re: I2C EEPROM Interface with KC705 board

Jump to solution
This issue seems got fixed in vivado 2014.4 I would like to know which version you are using at your end
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
8,895 Views
Registered: ‎08-01-2008

Re: I2C EEPROM Interface with KC705 board

Jump to solution
This issue seems got fixed in vivado 2014.4 I would like to know which version you are using at your end
Thanks and Regards
Balkrishan
--------------------------------------------------------------------------------------------
Please mark the post as an answer "Accept as solution" in case it helped resolve your query.
Give kudos in case a post in case it guided to the solution.

View solution in original post

0 Kudos
Participant jacob.varghese
Participant
4,713 Views
Registered: ‎05-28-2015

Re: I2C EEPROM Interface with KC705 board

Jump to solution

Thanks for Replying

 

I am using Xilinx 14.7, Can you suggest me any workaround for this problem.

 

Many Thanks

Jacob

0 Kudos
Xilinx Employee
Xilinx Employee
4,689 Views
Registered: ‎07-01-2010

Re: I2C EEPROM Interface with KC705 board

Jump to solution

@jacob.varghese

 

If you are using xiic_eeprom_example.c targeting KC705 board you are supposed to make the below change in xiic_eeprom_example.c.

 

/*
* This define should be uncommented if there is IIC MUX on the board to which
* this EEPROM is connected. The boards that have IIC MUX are KC705/ZC702/ZC706.
*/
/* #define IIC_MUX_ENABLE */

 

Did you uncomment this?

 

-Achutha

---------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------
0 Kudos
Participant jacob.varghese
Participant
4,679 Views
Registered: ‎05-28-2015

Re: I2C EEPROM Interface with KC705 board

Jump to solution

 Hello achutha, 

 

It is uncommented.

 

MUX_ADDRESS                         : 0x74

CHANNEL                                    : 0x08

SLAVE ADDRESS(EEPROM)  : 0x54

 

 

 

0 Kudos
Participant jacob.varghese
Participant
4,666 Views
Registered: ‎05-28-2015

Re: I2C EEPROM Interface with KC705 board

Jump to solution

Hello Balkrishan,

 

I tried with same code in Vivado 2015.2,but same issue prevails.

 

Please help me out. 

0 Kudos
Highlighted
Participant jacob.varghese
Participant
4,653 Views
Registered: ‎05-28-2015

Re: I2C EEPROM Interface with KC705 board

Jump to solution

Hello BalKrishan,

 

Sorry for my Ignorance......

 

I2C interface is working.Actually I didnot set MUX RESET PIN before.....

 

Can you Please State what is the Issue in PlanAhead 14.7 and other lower versions?

0 Kudos