cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ali
Newbie
Newbie
3,629 Views
Registered: ‎03-17-2017

Node locked license problem vc7

Jump to solution

Hello,

 

I have generated with my voucher of virtex-7 a node locked license, I have loaded it in Vivado and the license 

manager shows that it was successfully loaded

Screenshot_2017-03-17_16-46-24.png

 

However I'm not able to synthesis the design, Vivado is saying that I need a valid license for xc7vx485t, which I have loaded earlier

 

Screenshot_2017-03-17_16-46-42.png

 

Any help is appreciated

Screenshot_2017-03-17_16-46-24.png
0 Kudos
1 Solution

Accepted Solutions
nupurs
Moderator
Moderator
6,597 Views
Registered: ‎06-24-2015

@ali,

 

You need to change the NIC naming convention tto ethX.

Refer this AR for details: https://www.xilinx.com/support/answers/60510.html

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).

View solution in original post

0 Kudos
7 Replies
ashishd
Xilinx Employee
Xilinx Employee
3,624 Views
Registered: ‎02-14-2014

Hello @ali,

 

Can you share the output of below command along with license file here -

report_environment -file <directory_name>/xinfo.txt

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
ali
Newbie
Newbie
3,618 Views
Registered: ‎03-17-2017

xinfo.txt

0 Kudos
ashishd
Xilinx Employee
Xilinx Employee
3,614 Views
Registered: ‎02-14-2014

Hello @ali,

 

Are you using supported version of Ubuntu OS? Only Ubuntu Linux 16.04 LTS (64-bit) is supported with Vivado 2016.4.

The license you have generated is unable to lock to your system host ID. Hence you are facing this error.

Can you attach license here ? 

Regards,
Ashish
----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.
Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
ali
Newbie
Newbie
3,612 Views
Registered: ‎03-17-2017

Yes I'm using Ubuntu 16.04 LTS (linux lite 3.2 is basically ubuntu 16.04 lts with xfce desktop environment).

 

 

0 Kudos
nupurs
Moderator
Moderator
6,598 Views
Registered: ‎06-24-2015

@ali,

 

You need to change the NIC naming convention tto ethX.

Refer this AR for details: https://www.xilinx.com/support/answers/60510.html

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).

View solution in original post

0 Kudos
ali
Newbie
Newbie
3,593 Views
Registered: ‎03-17-2017

For reference I have disabled the new network naming schema, by editing /etc/default/grub

GRUB_CMDLINE_LINUX="net.ifnames=0"

 

sudo update-grub2

 

And Vivado works as expected!

 

Thanks very much for the quick help.

0 Kudos
nupurs
Moderator
Moderator
3,579 Views
Registered: ‎06-24-2015

@ali,

 

Glad to know that your issue is resolved.

Please close this thread by marking appropriate reply as "Accept as solution".

Thanks,
Nupur
--------------------------------------------------------------------------------------------
Google your question before posting. If someone's post answers your question, mark the post as answer with "Accept as solution". If you see a particularly good and informative post, consider giving it Kudos (click on the 'thumbs-up' button).
0 Kudos