cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
iwantxillic11
Visitor
Visitor
7,615 Views
Registered: ‎03-01-2013

Planahead 14.4 not starting on Ubuntu 14.4

Jump to solution

Planahead 14.4 does not start in gui mode in Ubuntu 12.04. TCl mode of the tool works fine though.

 

The command and output are as follows.

 

$ planAhead

****** PlanAhead v14.4 (64-bit)
  **** Build 222254 by xbuild on Tue Dec 18 05:17:28 MST 2012
    ** Copyright 1986-1999, 2001-2012 Xilinx, Inc. All Rights Reserved.

INFO: [Common 17-78] Attempting to get a license: PlanAhead
INFO: [Common 17-290] Got license for PlanAhead
INFO: [Device 21-36] Loading parts and site information from /work/xilinx/14.4/ISE_DS/PlanAhead/data/parts/arch.xml
Parsing RTL primitives file [/work/xilinx/14.4/ISE_DS/PlanAhead/data/parts/xilinx/rtl/prims/rtl_prims.xml]
Finished parsing RTL primitives file [/work/xilinx/14.4/ISE_DS/PlanAhead/data/parts/xilinx/rtl/prims/rtl_prims.xml]
start_gui
null
$

 

A debug log file is created along with the normal jou and lof files of planahead in the working directory.

The file is attached with this post.

 

The problem appears to be some java error according to the debug file. I could not find the pertinent file or dependency for resolving it.

 

Other details:

OS : Ubuntu 12.04 Precise 64 bit

Java version :  "1.7.0_15"
OpenJDK Runtime Environment (IcedTea7 2.3.7) (7u15-2.3.7-0ubuntu1~12.04)
OpenJDK 64-Bit Server VM (build 23.7-b01, mixed mode)

 

PS : Other tools in the suite work fine. (ISE, XPS, and SDK)

 

Please help!!

 

 

0 Kudos
1 Solution

Accepted Solutions
mcgett
Xilinx Employee
Xilinx Employee
8,782 Views
Registered: ‎01-03-2008

My prior reply appears to have been lost when one of the posts in this thread was deleted.

 

Ubuntu is not a supported Linux OS distribution, but Red Hat Enterprise 5 & 6 are supported along with SUSE Enterprise 11.  There are differences between Linux distribution and this can cause incompatabilities with the Xilinx software.  Since this not a supported OS there are very few people on the forums that have the same setup and could provide any assistance and a smaller set of people that are also using PlanAhead at the same time.

 

There is a sub-forum for PlanAhead discussion (Design Tools -> Planning Issues) where you might find someone that could help, but you might not due to the OS that you are using.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com

View solution in original post

0 Kudos
9 Replies
iwantxillic11
Visitor
Visitor
7,602 Views
Registered: ‎03-01-2013

Anyone??

 

Please reply!!

0 Kudos
iwantxillic11
Visitor
Visitor
7,589 Views
Registered: ‎03-01-2013

Correction : Ubuntu 12.04

Sorry

0 Kudos
7,585 Views
Registered: ‎03-05-2013

No use trying to ask question here!!!

 

No one cares at all...

Whereas I find replies to the most crappy question by others!!!

 

Hope some contributors see this!!!

 

 

 

------

Yes, I mean what I say about this stupid forum

patelalap11
Newbie
Newbie
7,584 Views
Registered: ‎03-05-2013

My dear friend,

I fear the most intelligent answer that you can get from this forum is to reinstall Ubuntu. :P

bassman59
Historian
Historian
7,094 Views
Registered: ‎02-25-2008

Well, Ubuntu isn't one of the supported operating systems, so you're own your own.

----------------------------Yes, I do this for a living.
0 Kudos
mcgett
Xilinx Employee
Xilinx Employee
8,783 Views
Registered: ‎01-03-2008

My prior reply appears to have been lost when one of the posts in this thread was deleted.

 

Ubuntu is not a supported Linux OS distribution, but Red Hat Enterprise 5 & 6 are supported along with SUSE Enterprise 11.  There are differences between Linux distribution and this can cause incompatabilities with the Xilinx software.  Since this not a supported OS there are very few people on the forums that have the same setup and could provide any assistance and a smaller set of people that are also using PlanAhead at the same time.

 

There is a sub-forum for PlanAhead discussion (Design Tools -> Planning Issues) where you might find someone that could help, but you might not due to the OS that you are using.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com

View solution in original post

0 Kudos
iwantxillic11
Visitor
Visitor
7,068 Views
Registered: ‎03-01-2013

I will wait for someone who is currently in the same state as me...

Have seen a lot of posts on the forum with people using xilinx in ubuntu

 

Hope someone replies :(

0 Kudos
iwantxillic11
Visitor
Visitor
7,067 Views
Registered: ‎03-01-2013
Also will post on the licensing forum ..
0 Kudos
mcgett
Xilinx Employee
Xilinx Employee
7,060 Views
Registered: ‎01-03-2008

> Also will post on the licensing forum ..

 

Why?  Your issue has nothing to do with the licensing?

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com