cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
2,711 Views
Registered: ‎09-14-2010

Problem with System Generator

i am using System Generator 13.4 qith MATLAB 2011a ....

 

whenever i drag a block into my design and try to run it it gives me following message and error...

 

 

"Error reported by S-function 'sysgen......'"

 

my aim is to design atleast 4 tap floating-point FIR filter but it is not letting me do anything.

 

i will be grateful for your kind help

 

thanks

0 Kudos
3 Replies
Highlighted
Teacher
Teacher
2,708 Views
Registered: ‎08-14-2007

Re: Problem with System Generator

Hi,

the tool versions seem to match.

 

The error message is very common, and so it can have many causes.

Maybe you can post the whole message and/or a screenshot of your simulink model.

 

(You do have Gateway blocks and the System Generator block in your design, don't you?)

 

Have a nice simulation

  Eilert

0 Kudos
Highlighted
2,706 Views
Registered: ‎09-14-2010

Re: Problem with System Generator

thanks Eilert

overome this problem and stucked in other now. i just posted it again in my new post undr Callbacks in System Generator as my callback function isnt working. i will be grateful for your kind suggestions here also.

thanks and regards
0 Kudos
Highlighted
Explorer
Explorer
2,693 Views
Registered: ‎04-28-2010

Re: Problem with System Generator

hi,

     If you have a start and stop function then under the file select the model properties then under the callbacks select the proper start and stop function...

 

Best Regards

Chandra

university of calcutta

Best Regards
Chandrajit
0 Kudos