cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
pretender17
Observer
Observer
2,682 Views
Registered: ‎06-08-2011

Vivado 2016.2 third party simulation with Modelsim DE

I was wondering if anyone else has seen this issue,...

 

Tools:

Vivado 2016 Design Edition, floating license.

ModelSim DE 10.5b.

Windows 7 Pro 64-bit.

 

Trying to do a full chip simulation using Modelsim.

Design has an embedded CPU subsystem.

 

After setting up the simulation environment, i.e. compiling simulation libraries, etc., I enter "launch_simulation" TCL command.

compile script is generated, and the Modelsim begins executing this script.

 

It works its way down into the script where I get the following error:

 

# Model Technology ModelSim DE-64 vcom 10.5b Compiler 2016.05 May 21 2016
# Start time: 17:07:04 on Mar 16,2017
# vcom -64 -93 -work xil_defaultlib ../../../digipim_project_proto1_master.ip_user_files/bd/cpu_subsystem/ip/cpu_subsystem_dlmb_bram_if_cntlr_0/sim/cpu_subsystem_dlmb_bram_if_cntlr_0.vhd ../../../digipim_project_proto1_master.ip_user_files/bd/cpu_subsystem/ip/cpu_subsystem_ilmb_bram_if_cntlr_0/sim/cpu_subsystem_ilmb_bram_if_cntlr_0.vhd
# ** Error: (vcom-7) Failed to open design unit file "../../../digipim_project_proto1_master.ip_user_files/bd/cpu_subsystem/ip/cpu_subsystem_dlmb_bram_if_cntlr_0/sim/cpu_subsystem_dlmb_bram_if_cntlr_0.vhd" in read mode.
# No such file or directory. (errno = ENOENT)
# End time: 17:07:04 on Mar 16,2017, Elapsed time: 0:00:00
# Errors: 1, Warnings: 1
# ** Error: C:/modelsim_dlx64_10.5b/win64pe/vcom failed.
# Error in macro ./digipim_top_tb_compile.do line 145
# C:/modelsim_dlx64_10.5b/win64pe/vcom failed.
# while executing
# "vcom -64 -93 -work xil_defaultlib \
# "../../../digipim_project_proto1_master.ip_user_files/bd/cpu_subsystem/ip/cpu_subsystem_dlmb_bram_if_cntlr_0/sim/..."

 

 

Now it appears from the error that the simulation compile script is unable to locate a particular file that is part of the CPU subsystem, but I follow the path and the file is not only there, but I can open it and view it.  Its just a .vhd file.

 

I have tried not using containers, tried completely regenerating the CPU subsystem, made sure that the file is not hidden or anything, even rebooted my machine.  I don't see why the script says that it cannot locate the file.

 

 

Script fails at line 145.  Same place every time.  Same reason given.

 

Attached is the modelsim compile script.

 

Any ideas?

 

0 Kudos
1 Reply
florentw
Moderator
Moderator
2,647 Views
Registered: ‎11-09-2015

Hi @pretender17,

 

Please make sure that:

-> you have the correct permission to read the folder

-> you have no blank space in the path (or special characters as ~ # { } etc...)

 

Regards,

 

Florent


Florent
Product Application Engineer - Xilinx Technical Support EMEA
**~ Don't forget to reply, give kudos, and accept as solution.~**
0 Kudos