cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
kemaangu
Visitor
Visitor
4,668 Views
Registered: ‎09-09-2015

data abort on uboot

Hi

I am using xilinx zynq zc702 rev 1.1 board .  All these time things are working. Suddenly at boot gets the following set of errors on booting u-boot from SD MMC card : 

 

1. Some time on typing print command from uboot prompt gets the following error.  

 

 

----------------

stdout=serial
uenvboot=if run loadbootenv; then echo Loaded environment from ${bootenv}; run importbootenv; fi; if test -n $uenvcmd; then echo Running uenvcmd ...; run uenvcmd; fi
usbboot=if usb start; then run uenvboot; echo Copying Linux from USB to RAM... && fatload usb 0 0x3000000 ${kernel_image} && fatload usb 0 0x2A00000 ${devicetree_image} && fatload usb 0 0x2000000 ${ramdisk
_image} && bootm 0x3000000 0x2000000 0x2A00000; fi

Environment size: 3368/131068 bytes
data abort

    MAYBE you should read doc/README.arm-unaligned-accesses

pc : [<3ff7d05c>]          lr : [<3ff5ae14>]
sp : 3fb2fe30  ip : 00000000     fp : 3fb30528
r10: 3ff8c29a  r9 : 3fb2ff38     r8 : 00000002
r7 : 00000000  r6 : 00000000     r5 : 3fb2fe84  r4 : 3ff99c1c
r3 : 00000000  r2 : 3fb2fefc     r1 : 00000000  r0 : 00000002
Flags: nzCv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

resetting ...


U-Boot 2014.01 (Apr 08 2014 - 09:46:56)

I2C:   ready
Memory: ECC disabled

------------------

2. On loading the image through tftpboot gets the following error.

 

------------------

Environment size: 3368/131068 bytes
zynq-uboot> setenv ipaddr 10.162.103.128;setenv serverip 10.162.103.232
zynq-uboot> set rootpath /mnt/xilinx-zynq;setenv bootargs console=ttyPS0,115200 root=/dev/nfs rw nfsroot=${serverip}:${rootpath} ip=dhcp;tftpboot 0x3000000 uImage; tftpboot 0x2A00000 zynq-zc702.dtb;bootm 0
x3000000 - 0x2A00000
Gem.e000b000 Waiting for PHY auto negotiation to complete....... done
Using Gem.e000b000 device
TFTP from server 10.162.103.232; our IP address is 10.162.103.128
Filename 'uImage'.
Load address: 0x3000000
Loading: undefined instruction
pc : [<1d000004>]          lr : [<3ff8707c>]
sp : 3fb2fd68  ip : 00000000     fp : 3ffecc38
r10: 3fb34260  r9 : 3fb2ff38     r8 : 00000000
r7 : 3fc00040  r6 : 3fc00040     r5 : 3fb34260  r4 : 3fb303f8
r3 : 1d000000  r2 : 0000003c     r1 : 0000003c  r0 : 3fb34260
Flags: nzCv  IRQs off  FIQs off  Mode SVC_32
Resetting CPU ...

resetting ...


U-Boot 2014.01 (Apr 08 2014 - 09:46:56)

I2C:   ready
Memory: ECC disabled
DRAM:  1 GiB
MMC:   zynq_sdhci: 0
SF: Detected N25Q128A with page size 256 Bytes, erase size 64 KiB, total 16 MiB
In:    serial
Out:   serial
Err:   serial
Net:   Gem.e000b000
Hit any key to stop autoboot:  0
zynq-uboot>

-------------------------------

 

3. some time uboot command hangs.

 

Please help me out to recover the board to normal state. Is SPI flash has corrupted?

 

Thanks & Reagards

Manjunatha Srinivasan

 

 

 

 

 

 

 

 

0 Kudos
1 Reply
kemaangu
Visitor
Visitor
4,647 Views
Registered: ‎09-09-2015

Hi

Any updates on this issue.  Thanks.

 

0 Kudos