UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Adventurer
Adventurer
315 Views
Registered: ‎09-28-2018

2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi Xilinx, 

I'm having troubles changing the FMC voltage, in fact I'm struggling to make any connection to the MSP430 using the BoardUI.exe, Board User Interface.

I can however connect manually to the COM6 serial port and issue the command "@ver" . So the setup works in this sense.  I also made some attempts to change the advanced port settings to see if there ar no fifo ques which can cause a timeout.  -> No result

As for a firmware upgrade: Also there are complaints about not finding the correct com port, although I filled in the right one in the default.json and the "firmware_flash_gui..  ..bat:  file

 

Can you please give some support about this issue Xilinx?

 

Thanks in advance 

Deville

 

Edit: Any manual commands addressing the MSP430 you can share, are very much welcome.

 

print11.pngprint12.pngprint13.png

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
214 Views
Registered: ‎06-06-2018

Re: 2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi @deville ,

Your PC has Driver version of 10.1.8, Please uninstall that Silicon Labs Driver version 10.1.8 from your PC and install Silicon Labs 6.7 driver version . After installing 6.7 Driver version, try using Board UI and share the results.

Note : Even though Silicon Labs 6.7 driver version  is unsupported for Windows 10, please still proceed and install, it will work.

Regards,

Deepak D N

----------------------------------------------------------------------------------------

Please Kudo and Accept as a Solution, if it helps.

----------------------------------------------------------------------------------------

 

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------

View solution in original post

5 Replies
Xilinx Employee
Xilinx Employee
274 Views
Registered: ‎06-06-2018

Re: 2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi @deville ,

I obsereved that you UART Cable is getting detected has Silicon Labs CP2108. If it gets detected has CP210x then you will have succesfull interface with Board UI. To make it get detected has CP210x please refer this AR#68521 .

 

>> Please share OS details and Silicon Labs Driver version? You can get the Silicon Labs driver version by right clicking.

Regards,

Deepak D N

----------------------------------------------------------------------------------------

Please Kudo or Accept as a Solution, if it helps.

----------------------------------------------------------------------------------------

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------
Adventurer
Adventurer
220 Views
Registered: ‎09-28-2018

Re: 2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi @ddn 

Thanks for yout reply. I've included screenshots of the settings I made and the things you've asked. 

print14.png

 

print15.png

 

print16.png

 

Paint17.png

 

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
215 Views
Registered: ‎06-06-2018

Re: 2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi @deville ,

Your PC has Driver version of 10.1.8, Please uninstall that Silicon Labs Driver version 10.1.8 from your PC and install Silicon Labs 6.7 driver version . After installing 6.7 Driver version, try using Board UI and share the results.

Note : Even though Silicon Labs 6.7 driver version  is unsupported for Windows 10, please still proceed and install, it will work.

Regards,

Deepak D N

----------------------------------------------------------------------------------------

Please Kudo and Accept as a Solution, if it helps.

----------------------------------------------------------------------------------------

 

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------

View solution in original post

Adventurer
Adventurer
187 Views
Registered: ‎09-28-2018

Re: 2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi @ddn 

 

Thanks for the help. BTW.

I've downgraded the driver but no such luck. Neither "Bit.exe" nor "BoardUI.exe" recognises the COM port. Can you share the commands for FMC settings through a regular terminal client?  

 

paint18.png

 

paint19.png

 

 

0 Kudos
Adventurer
Adventurer
141 Views
Registered: ‎09-28-2018

Re: 2018.2: ZCU102: Can't make a connection with the MSP430

Jump to solution

Hi @ddn 

Allright!  I've made some adjustments like you suggested.  I've downgraded the driver again to 6.7.  This was not helpful but then I tried the other thing you've suggested: 

Also downgrading the ZCU102 SCUI.exe application:  Link to version : XTP433 V3   I tried the latest version in my previous effort. 

This was more successful. I could readout and set the FMC V adjust voltages like you would expect from this piece of software.

print20.png

paint21.png

 

Thanks again for the assistance. 

0 Kudos