cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Anonymous
Not applicable
7,805 Views

Digilent Adept software doesn't find the CoolRunner2 board

After about a year of disuse, Digilent's Adept software no longer works with the CoolRunner2 board. It enumerates fine as a USB device, but Adept reports that it cannot initialize the device chain. The CoolRunner-II Utility Window 1.0 application similarly reports "Unable to Connec to device for programming. Check connections and try again."

 

I have tried various versions of Adept software, downloaded from Digilent's site as well as the CD image on xilinx.com. The results are consistently no connection. The sotware versions were labeled DAS 2.0, DAS 1.10, and the CRII-UW from the installation CD. Oddly, the Adept 2.0 installation reports that it is version 1.05 in the status window. The drivers for that version, though, were much more recent than in others, from 5/2009. I've tried several iterations of completely uninstalling before reinstalling, including uninstalling the device driver from USB such that Windows displays the new device wizard when the device is plugged in.

 

The device enumerates in XP's Device Manager. ExPort's configure screen shows one connected device, 'Cr2s2', Connect: 'SN:10146d123456'.

 

The device programs fine through iMPACT using fly leads on the USB platform cable. It isn't a complete showstopper, but this ties up the programming cable.

 

Any help restoring Adept programming through USB to this board is greatly appreciated. Thanks.

 

---------

 

Incidentally, for those interested, Digilent has a utility for dowload that programs the AVR AT90USB162 device on the CR2 board. This is now of passing interest to me since the device no longer serves a useful role in programming the CPLD. There's very little like burning the boats to commit to the course at hand... Alas, it's utility with the demo board is limited because it shares very little I/O with the CPLD.

 

 

 

 

0 Kudos
2 Replies
Highlighted
Newbie
Newbie
6,267 Views
Registered: ‎09-16-2010

Re: Digilent Adept software doesn't find the CoolRunner2 board

Bump! I want to see this work or be given the tools necessary to fix it myself!

 

EDIT: Interestingly enough, I switched over from USB power to external power and was able to get one step further.

 

Now my USB chip is overheating. Perhaps the Coolrunner II board is not the way to go.

 

Cheers,

Joe

0 Kudos
Highlighted
Newbie
Newbie
5,570 Views
Registered: ‎04-11-2011

Re: Digilent Adept software doesn't find the CoolRunner2 board

I had the same problem while installing PC's in a classroom. I installed ISE 13.1 but the utility window gave errors. Tried everything, and got the system working by installing a previous version (ISE 11.1) alongside ISE 13.1.

Hopefully this helps others too...

0 Kudos