UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor atehor
Visitor
9,414 Views
Registered: ‎09-10-2012

KC705 PCIe not working when connected to a PC

Hello Xilinx community,

 

Currently I own a KC705 Evaluation Board Rev 1.0. I'm working on a project where I need to setup a PCIe communication between two devices, so in order to test if the PCIe module on the KC705 is working I followed the "KC705 PCIe Design Creation" document provided by Xilinx. I did every step stated on the document and I can succesfully program the BPI Flash with the .bit file implemented. So then I plug the KC705 Card on the x16 PCIe socket of my desktop PC (Motherboard Foxconn H61MXV), turn the PC on and open up the PCITREE application to check the device, but, surprise, it is not being detected.

 

I repeated the steps, creating a new project and everything, but nothing, I even downloaded the PCIe files from Xilinx website and just burn it onto the FPGA, and it didnt work either. I double checked the jumpers and switches and problem persists so I'm basically stuck at this very early stage of my project.

 

Does anyone have experienced such problem? or maybe if one of the Xilinx Experts could give me a hand on this I'd be very much thankful.

 

Warm Regards,

 

Andrés

0 Kudos
12 Replies
Voyager
Voyager
9,403 Views
Registered: ‎05-21-2008

Re: KC705 PCIe not working when connected to a PC

can you check if fpga is configurated successfully? check if DONE is asserted. then reset PC (soft reset button) and check if it can be detected.
0 Kudos
Visitor atehor
Visitor
9,392 Views
Registered: ‎09-10-2012

Re: KC705 PCIe not working when connected to a PC

Hello, thx for the prompt answer,

 

Well I checked the DONE LED and in deed it gets asserted when the programming is done, I also tried to reboot the PC while the card was still connected but it didn't make any difference. 

 

I'm starting to think it might be some sort of conflict of the PCIe port, when I run the PCITREE app, it presents all the devices attached and I can see my Ethernet module is a PCIe one, so I dont know if this could be interfiering with the KC705 card.

 

I attached a screenshot of my PCITREE information. FYI, I'm using Windows 7 32bits.

 

Any more ideas? I'm very frustrated.

 

Warm regards

 

Andrés

PCITREE Status.png
0 Kudos
Observer patrickyip
Observer
9,385 Views
Registered: ‎08-06-2012

Re: KC705 PCIe not working when connected to a PC

Install Win XP.

Xilinx supports Win XP currently. Xilinx is outdated in supporting the new OS. I have asked Xilinx in webcase and they replied (recently) that they have no plan on Win7 or Win8.

0 Kudos
Observer patrickyip
Observer
9,383 Views
Registered: ‎08-06-2012

Re: KC705 PCIe not working when connected to a PC

Also the PCItree cannot run on Win7 64-bit. But i am not sure on 32-bit.

0 Kudos
Visitor siziegler
Visitor
9,229 Views
Registered: ‎10-30-2012

Re: KC705 PCIe not working when connected to a PC

Hi Andrés

 

Did you find a solution for this problem? I encounter the symptoms same at this very moment..

 

-Sil

 

0 Kudos
Visitor pvandoren
Visitor
9,038 Views
Registered: ‎01-04-2013

Re: KC705 PCIe not working when connected to a PC

Hi All:

 

I have a similar issue with KC705 board version 1.1:  In my case, I'm just attemting to get the Advance Bringup Using the Base Targeted Reference Design up and running on the provided fedora linux.  The first indication that something is wrong, is the LED0 never comes on which sould state the PCIe link is up (Page 26-27 of UG883)  All other LED's are as expected.   The next issue is I do not see the Commincation Controller from Xilinx when I run lspci as stated on Paged 29.

 

I'm going to open a webcase, but it's not letting me rightnow.


Any tips/clues would be a huge help!

 

Thanks

 

Pete

 

0 Kudos
Newbie jncortes
Newbie
8,177 Views
Registered: ‎10-09-2013

Re: KC705 PCIe not working when connected to a PC

Hi pvandoren,

 

I experience exactly the same symptoms as you had. No link up, LED0 is off, evrything else shows up as expected.

Did you ever figure out what was the solution?

One thing I tried was to find the most recent .bit file for this TRD but could not find it either.

 

Thank you!

Jose

0 Kudos
Participant ribalda
Participant
7,907 Views
Registered: ‎06-16-2008

Re: KC705 PCIe not working when connected to a PC

Hello

 

Has anybody found a solution for this? I am struggling right now with this same issue.

 

I have tried with 3 different motherboards, and with self produced bitstreams and with the "ready_to_download" bitstreams.

 

Regards

0 Kudos
Xilinx Employee
Xilinx Employee
7,874 Views
Registered: ‎08-01-2012

Re: KC705 PCIe not working when connected to a PC

One of the below AR may help to fix your issue

 

http://www.xilinx.com/support/answers/51699.htm

http://www.xilinx.com/support/answers/52657.htm

http://www.xilinx.com/support/answers/44353.htm

 

Also in case if any board problem exists the following AR http://www.xilinx.com/support/answers/50079.htm helps to confirm that

________________________________________________

Please mark this post as an "Accept as solution" in case if it helped to resolve your query. So that it will help to other forum users to directly refer to the answer.

Give kudos to this post in case if you think the information is useful and reply oriented.

0 Kudos
Participant ribalda
Participant
3,550 Views
Registered: ‎06-16-2008

Re: KC705 PCIe not working when connected to a PC

Unfortunately the AR havent helped me with my issue. Attached you will find a chipscope session with my design.

 

It is a surprise that a refdesign is not working for so many people. In my case I am particuraly concern about the fact that the "ready_for_download" bitstream is not working in 3 different motherboards.

 

Maybe a malfunctioning batch of kc705 boards?

 

txdetectrx.png

0 Kudos
Xilinx Employee
Xilinx Employee
3,544 Views
Registered: ‎12-11-2012

Re: KC705 PCIe not working when connected to a PC

Hi,

Can you provide me the following details-

1. Which MotherBoard are you using?

2. Which TRD revision are you using?

3. Are you using JTAG mode of downloading the bitfile or you are loading the bitfile from BPI flash?

4. What revision of KC705 board are you using?

 

We have verified in our lab that the bitstream works on Z77, X-79 and ASUS Maximus MotherBoards.

Mrinal
0 Kudos
Participant ribalda
Participant
3,541 Views
Registered: ‎06-16-2008

Re: KC705 PCIe not working when connected to a PC

HARDWARE

============

 

The ev board has the following laels
FMC HPC
HW-KC705 REV. C
S/N 1135-249
whizzsystems.com
2C

I have tried with a pcie x16 to x1 finger adatper with no results. and
J32 in all the possible possitions.

I have used 3 different mother boards with different results

-100% intel. http://www.intel.com/p/en_US/support/highlights/dsktpboards/dh55tc
The system boots but the board is not enumerated

-100% amd with x1 finger:
http://www.amd.com/us/Documents/49286_Embedded_Solutions_Brief_FT1_web.pdf
The system boots but the board is not enumerated

-Lenovo desktop
The system does not POWER UP when the board is connected


Bitstream
========

3 different bitstreams

I have made my own project with the IP integrator using the pcie axi bridge

I have tried with the bit files from:
https://secure.xilinx.com/webreg/clickthrough.do?cid=354607&license=RefDesLicense&filename=rdf0187-kc705-pcie-c-2013-4.zip&languageID=1

And also following the instructions  from the .pdf to make my own project.

Allways the same results, the board is not enumerated.


Methodology
============

Two methods
-Power up
-Download bistream
-Remboot

or

-Download mcs
-Power up

RESULTS

=========
When I am using the demo design:

If the board is not connected:
LED 0 is "floating"

if the board is connected:
LED 0 is ON
LED 3 is blinking

Thanks for your help.

0 Kudos