cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
10,399 Views
Registered: ‎08-26-2015

KCU105 reboot problem

Issue with rebooting the KCU105 development card.

After running an application on my KCU105 development card for an hour or so and then rebooting by cycling the power it fails to initialize, and LED DS3 illuminates red together with LED DS18 not lit green. This I believe indicates a problem with the VCCAUX supply. If I leave the card powered down for a few minutes it boots up ok.

I have tried this on three different cards and get the following results...

743109961511-33389   - Always fails to reboot after warm up

743109961511-33424  - Occasionally fails to reboot after warm up

743109961510-32753  - Never fails to reboot after warm up

Does this suggest that there is a problem with a later batch of development cards?

A colleague noticed that one of your answer records AR#65218 mentions that…

“If power issues are encountered on the KCU105, reprogramming these

devices might become necessary, using the Maxim InTune PowerTool

cable.”

Could you please confirm as to whether or not this would cure the reboot problem and if not, what should I do to resolve the issue?

Thank you

Richard Phillips

 

11 Replies
Highlighted
Scholar
Scholar
10,369 Views
Registered: ‎02-27-2008

Re: KCU105 reboot problem

r,

 

First,  what are you loading into the device?  Did you exceed the power rating of the supply?

 

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
10,361 Views
Registered: ‎08-26-2015

Re: KCU105 reboot problem

Hi Austin

I don’t think that we are exceeding the capabilities of the card.

 

We’ve used the Xilinx IPI Reference design as a reference in our estimates for power usage. We thought that our code was similar enough to the Xilinx IPI Reference design that it should be ok.

 

I’ve attached the outputs from the power reports for our project. The estimated power usage for the Xilinx IPI project is higher than for ours.

Regards,

Richard Phillips

0 Kudos
Highlighted
Scholar
Scholar
10,353 Views
Registered: ‎02-27-2008

Re: KCU105 reboot problem

r,

 

The power report confidence is low, so it might be more watts than is estimated.  I would check the die temperature through the Vivado hardware monitor pull down screens.  Watch the die temperature after loading, and see what maximum value it reaches.

 

I am assuming this does not happen when no pattern is loaded (that the board itself is good until the bitstream is loaded).

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
10,298 Views
Registered: ‎08-26-2015

Re: KCU105 reboot problem

Hi Austin,

I've erased the configuration memory and I still get the reboot problem.

I also checked the die temperature as you suggest and after running the application code for about half an hour the temperature stabilizes at 33.6° C.

 

Regards,

Richard Phillips

0 Kudos
Highlighted
Scholar
Scholar
10,283 Views
Registered: ‎02-27-2008

Re: KCU105 reboot problem

r,

 

OK, that means there is something wrong on the board somewhere.  Go back to the distributor and start the discussion for getting them replaced/repaired.

 

 

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Highlighted
Visitor
Visitor
8,047 Views
Registered: ‎01-27-2010

Re: KCU105 reboot problem

Hi there,

 

I am having same/similar issues here. I programmed my card couple of times without any problem, but now I get DS18 off (VCCAUX_PGOOD low) and DS3 red. I also realized that it only happens if I try to download a MicroBlaze processor-based system to my board. Downloading another simple firmware seems to work just fine.

 

Did you solve your problem ? If yes, what was the solution ?

 

Cheers, Csaba

Csaba
0 Kudos
Highlighted
Scholar
Scholar
8,040 Views
Registered: ‎06-05-2013

Re: KCU105 reboot problem

@csaba.soos This thread is closed and old. It is good practice to start a new thread to get the quick attentation.

 

Did you see this problem when loading Xilinx design files provided with the board?

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Visitor
Visitor
8,034 Views
Registered: ‎08-26-2015

Re: KCU105 reboot problem

The problem was fixed by obtaining a Maxim PMSbus dongle (free of charge from Maxim) and using the attached XML file to re-program the voltage regulators - don't use the XML file from the web site as it makes matters worse!

Highlighted
Visitor
Visitor
8,028 Views
Registered: ‎01-27-2010

Re: KCU105 reboot problem

Hi Pratham,

 

thank you for replying. I tried the KCU105_IPI design (version 2016.1) and it does fail too. While trying to debug, 1 out many attempts I got it working again, but it keeps failing other times. Most of the time VCCAUX shuts down, but a couple of times I had VCC1V2 failing.

 

Regards, Csaba

Csaba
0 Kudos
Highlighted
Visitor
Visitor
5,174 Views
Registered: ‎01-27-2010

Re: KCU105 reboot problem

Thank you for your reply. I just ordered the free dongle. We shall see what happens when I program the controller.

 

Regards, Csaba

Csaba
0 Kudos
Highlighted
Scholar
Scholar
5,173 Views
Registered: ‎06-05-2013

Re: KCU105 reboot problem

@rep1 Okay, Let us know the result after reprogramming power controllers.

-Pratham

----------------------------------------------------------------------------------------------
Kindly note- Please mark the Answer as "Accept as solution" if information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
----------------------------------------------------------------------------------------------
0 Kudos