UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor gndrix
Visitor
5,167 Views
Registered: ‎04-25-2011

ML507 board revisions

Hello, we are working with embedded linux on the ML507 board with a power PC into the virtex 5. The linux distributions are generated using POKY platform builder. We have two ML507, one with a "rev 1" tag on the bag it comes packed in, the other one says "rev 4". in "rev 1" everything runs just fine, the bitstream is written from the compact flash and the linux system is started through u-boot without any trouble. Unfortunately on rev 4 it does not work. Which are the differences (if any) between rev 1 and rev 4. We think there must be something different and haven't found any info about it.

 

Thanks in advance

0 Kudos
5 Replies
Scholar austin
Scholar
5,164 Views
Registered: ‎02-27-2008

Re: ML507 board revisions

Did you read through this thread:
http://forums.xilinx.com/t5/Embedded-Linux/ML507-and-marvell-88E1111-revisions/td-p/119546/page/2

I suspect that similar to that post, the problem has nothing to do with linux....

Austin Lesea
Principal Engineer
Xilinx San Jose
0 Kudos
Teacher eteam00
Teacher
5,162 Views
Registered: ‎07-21-2009

Re: ML507 board revisions


@austin.lesea wrote:
Did you read through this thread:
http://forums.xilinx.com/t5/Embedded-Linux/ML507-and-marvell-88E1111-revisions/td-p/119546/page/2

I suspect that similar to that post, the problem has nothing to do with linux....


Use this thread link instead, in case you have trouble:

http://forums.xilinx.com/t5/Embedded-Linux/ML507-and-marvell-88E1111-revisions/td-p/119546

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos
Visitor gndrix
Visitor
5,154 Views
Registered: ‎04-25-2011

Re: ML507 board revisions

Thanks for your answers, i've already read that thread, I do think it something similar. What I think is that the problem has nothing to do with linux as it runs correctly on the old board. So we think there's something different with the hardware, or some parameter related to it in the new board rev 4. Where would you suggest to start digging?. In the new board the boot process stops because some environment variables are missing for u-boot to use them. So I add them by hand and doing this the bitstream can be written and u-boot knows what to boot (:S). Unfortunately, after, uncompressing the kernel image and loading the device three, it stops working. Any suggestion?. Any hint would be greatly appreciated!

 

Thanks in advance.

0 Kudos
Xilinx Employee
Xilinx Employee
5,145 Views
Registered: ‎01-03-2008

Re: ML507 board revisions

 > So we think there's something different with the hardware, or some parameter related to it in the new board rev 4.

 

There was only a single PCB version of the ML507 released and that is Rev A.  If your two boards have labels that say rev 1 and 4 this is something that someone on your team did.

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
Visitor gndrix
Visitor
5,125 Views
Registered: ‎04-25-2011

Re: ML507 board revisions

> There was only a single PCB version of the ML507 released and that is Rev A.  If your two boards have labels that say rev 1 and 4 this is something that someone on your team did.

 

Actually, we didn't, but maybe those labels doesn't mean anything. However, there must be some differences between the boards, it's just that we haven't found anything yet.

0 Kudos