UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor tsr3944
Visitor
468 Views
Registered: ‎12-23-2018

Program Device Error ZCU102

Jump to solution

I have a ZCU102 board. I am trying out the Xilinx IBERT tutorial. I am following all the steps shown no issues until towards the end.

When I generate my bit-stream, I generate without any errors (only a few warning).

After that, I go ahead to the process to uploading it into my board.

However, when I click "Program Device" to upload my program onto my device, I get this error "[Labtools 27-3176]-hw_server failed during internal command".

Has anyone encountered this error before? Can you tell me what the error is this and why am I getting this error? What can I do to solve this issue?

I am not developing anything new, I am just following Xilinx's IBERT tutorial step by step and I am encountering this error at the very end when I try to upload the program onto the board.

Thank you!

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
331 Views
Registered: ‎06-13-2018

Re: Program Device Error ZCU102

Jump to solution

Hello @tsr3944,

Can you please share the following details with us:

1. Which Vivado version you using?

2. Did you follow the steps which is mentioned in the ug936 ?

3. What is the line rate you are targeting?

4. Please share the log file with us.

5. Try to run the example design from below link:

(https://www.xilinx.com/member/forms/download/design-license.html?cid=62103ce1-62b9-4831-8979-00cc9290ae34&filename=rdf0379-zcu102-ibert-c-2018-2.zip)

Regards,

Naveen

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------

5 Replies
Xilinx Employee
Xilinx Employee
355 Views
Registered: ‎06-21-2018

Re: Program Device Error ZCU102

Jump to solution

Hi tsr3944,

Can you provide the full output? Are there any errors before that one?

Thanks,
Andres

 

0 Kudos
Xilinx Employee
Xilinx Employee
332 Views
Registered: ‎06-13-2018

Re: Program Device Error ZCU102

Jump to solution

Hello @tsr3944,

Can you please share the following details with us:

1. Which Vivado version you using?

2. Did you follow the steps which is mentioned in the ug936 ?

3. What is the line rate you are targeting?

4. Please share the log file with us.

5. Try to run the example design from below link:

(https://www.xilinx.com/member/forms/download/design-license.html?cid=62103ce1-62b9-4831-8979-00cc9290ae34&filename=rdf0379-zcu102-ibert-c-2018-2.zip)

Regards,

Naveen

 

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------

Visitor tsr3944
Visitor
305 Views
Registered: ‎12-23-2018

Re: Program Device Error ZCU102

Jump to solution

1. Which Vivado version you using?

I an using Vivado 2018.2

2. Did you follow the steps which is mentioned in the ug936 ?

I have not yet gone through the Lab 10 debug process but I will now.

3. What is the line rate you are targeting?

I am using the example Line Rate = 10.3125 Gbps given for SFP IBERT Tutorial (XTP430) 

4. Please share the log file with us.

I believe these are the files...attached. 

5. Try to run the example design from below link:

Okay, I will do this next. Thanks!

0 Kudos
Xilinx Employee
Xilinx Employee
266 Views
Registered: ‎06-13-2018

Re: Program Device Error ZCU102

Jump to solution

Hello @tsr3944,

Did you get a chance to go through the debugging steps mentioned in UG936 and run the example design?

If your issue has been resolved, please mark this post as an accepted solution for the help of others.

Regards,

Naveen

------------------------------------------------------------------------------
Don't forget to reply, give kudo and accept as solution
------------------------------------------------------------------------------

0 Kudos
Visitor tsr3944
Visitor
250 Views
Registered: ‎12-23-2018

Re: Program Device Error ZCU102

Jump to solution

Yes, I did, thank you!

0 Kudos