cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
9,041 Views
Registered: ‎01-03-2010

USB Platform Cable Doesn't Work (Digilent Spartan 3E Board)

Has anyone else had an issue with the platform cable not working?  It used to when I was developing on a 64-bit Windows Server 2008 R2 RC machine, but when that machine was updated to a release version of 2008 R2 it ceased to be usable.  Frustrated, I tried again on other workstations that had Windows Vista SP2 x64 and Windows 7 x64 installed, but they both either failed to install the driver or the installer outright crashed during that step.  If I try to install the driver myself via device manager, the problem is a "Driver is not intended for this platform." error.  I've seen others, however.

 

I'm confused by this since I've seen it work before and it supposedly is supported on Vista x64 as per the Platform Cable FAQ:  http://www.xilinx.com/support/answers/20429.htm

0 Kudos
2 Replies
Highlighted
Newbie
Newbie
8,814 Views
Registered: ‎02-03-2010

I ran into the same problem earlier today.  I updated the xusbdrvr.inf files top header as follows:

 


CatalogFile.ntamd64=xusbdrvr.cat ; Use cat file on x64 only
;CatalogFile=xusbdrvr.cat ; Use cat for all OS types

 

This was on Win7/64-bit.

 

Hope you figured it out.

 

Chris

0 Kudos
Highlighted
Visitor
Visitor
7,065 Views
Registered: ‎01-25-2010

For me the cable does not work on Windows 7 x86 (32-bit) - it was working on WinXP! I have even downloaded the drivers provided on the cable installation site, but they does not work neither.

 

The driver provided with ISE 11.1 - it installs the driver but device is not working - cable driver needs to be reinstalled.

 

The driver provided on the Xilinx webstie (dated 2007) does not eve install as there are errors in *.inf file.

 

I just wonder why there is no ISE for FreeBSD :-(

 

Please advise,

0 Kudos