cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
ethanzhu
Visitor
Visitor
11,836 Views
Registered: ‎07-16-2014

VC707 BIST Implementation problems VC707 Virtex-7 FPGA Board

Right now, I connect the FPGA board to the 64bit Win7 laptop by UART
Port. Based on the instruction from the pdf of
"ug848-VC707-getting-started-guide" Page 6-8.
I have setup the  CP210x VCP drivers from silcon lab, but it still
cannot figure out this FPGA in device manager.
And I also try the method from the website:
http://www.chinstruments.com/USB_440.shtml

 

it shows "USB Deice Not Recognized".

USB UART Driver.PNG

it shows "unknown device" in the USB controller.

0 Kudos
6 Replies
tessitd
Explorer
Explorer
11,833 Views
Registered: ‎11-13-2009

I have found the following was necessary to get them to be seen:

 

1) Unplug the RS232 USB connector from the computer.

2) Turn off the VC707 Board.

3) Pulg the RS232 USB connector into the computer.

4) Wait 10 seconds or so for the computer to see the device.

5) Turn on the board.

6) Wait 10 second or so for the board to register with the computer.

7) Check it again -- hopefully this worked

 

IF NOT

 

1) Reboot with the VC707 Board off but the RS232 USB cable attached -- that has worked 100% of the time!

 

Silly I know,

TomT...

0 Kudos
mcgett
Xilinx Employee
Xilinx Employee
11,827 Views
Registered: ‎01-03-2008

The CP210x drivers will be under the "Ports (COM & LPT)" category, not the "Universal Serial Bus controllers".

------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
0 Kudos
ethanzhu
Visitor
Visitor
11,815 Views
Registered: ‎07-16-2014

I know it should under the "Ports(COM & LPT)" category, but the device manager don't show the category of "Ports(COM&LPT)" 

0 Kudos
ethanzhu
Visitor
Visitor
11,811 Views
Registered: ‎07-16-2014

Hi tessitd,

 

Thanks for your help. I have tried several times as your advice.

But the OS-Win7 64-bit still cannot find the driver for the UART Connection. And I setup the driver(CP210x USB to UART Bridge VCP Drivers version6.7) manually. The device manager shows aexclamation point.

Capture.PNG

AND the software"Tera Term", which is uesd to do BIST Test, doesn't show any series port.

Capture.PNG

Thanks for your help.

 

Best regards,

Ethan

 

0 Kudos
ethanzhu
Visitor
Visitor
11,808 Views
Registered: ‎07-16-2014

And also, may I know the driver that you used?
0 Kudos
tessitd
Explorer
Explorer
11,731 Views
Registered: ‎11-13-2009

Sorry for the delay I don't get to the forum every day -- need longer compile times to make that happen; but each release of the tool is just faster -- thanks Xilinx!

 

Driver Version is:

Silicon Laboratories

3/19/2014

6.7.0.0

 

Sounds like you should try a different USB port or computer as the Xilinx Employee said it should just show up.  My guess is that there is something loaded on your machine which is not allowing the driver to run.

 

Good Luck,

TomT...

 

0 Kudos