UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor greg_soe
Visitor
488 Views
Registered: ‎03-04-2019

VCU108 System Controller startup hanging

I have a VCU108 eval board and have been successfully using it for many months. However, today my board is failing to start up reliably. Earlier today it would startup successfully start up, seemly by chance. Now it consistently hangs at "Board Type = 0x06" on the UART output. When I press SW14, it tells me that it's "Unable to determine board type from EEPROM". Is there a way for me to reprogram the system controller's EEPROM? I've attached a text file of the startup log from the UART.

 

Thanks

0 Kudos
6 Replies
Xilinx Employee
Xilinx Employee
454 Views
Registered: ‎06-06-2018

Re: VCU108 System Controller startup hanging

Hi @greg_soe ,

1. Please share the OS and Vivado version? Board revision version?

2. Which version of USB UART Driver version you are using? Please share the snapshot of the USB UART Cable detection in Device manager (i.e silicon COM ports)?

3. Please share the POWER GOOD LEDS Snapshot? Please ensure that there is no Power fluctaion to the board?

4. Please confirm me that from VCU108 Debug Checklist, Till Step 4 you are fine?

 

Regards,

Deepak D N

--------------------------------------------------------------------------------------------

Please reply or Give kudo or MArk it as an Accepted Solution.

------------------------------------------------------------------------------------------

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------
0 Kudos
Visitor greg_soe
Visitor
441 Views
Registered: ‎03-04-2019

Re: VCU108 System Controller startup hanging

Hi ddn,

1. I'm running windows 10 with Vivado 2018.3. Board revision REV1.0 HW-U1-VCU108

2. I have driver version 10.1.4.2290 (screenshot attached)

3. Power looks good. (photos attached)

4. Everything powers up and appears in hardware manager.

 

NOTE: This morning, after leaving the board for a day, was operating normally after many power cycles. However, after trying to access the voltage/temp monitor functions in the System Controller menu, it hangs/freezes in those menus(ex: Continusus Scan SYSMON Measurements), and givers error messages. After power cycling the board, it becomes unreliable again, either successfully making it to the menu, or hanging just as the original description.

xilinx_com_ports.PNG
IMG_6257.JPG
IMG_6258.JPG
0 Kudos
Visitor greg_soe
Visitor
439 Views
Registered: ‎03-04-2019

Re: VCU108 System Controller startup hanging

I should clarify that the photos were taken when the board successfully started up.

0 Kudos
Xilinx Employee
Xilinx Employee
429 Views
Registered: ‎06-06-2018

Re: VCU108 System Controller startup hanging

Hi @greg_soe ,

Yes Power is fine from present images. please confirm me again.

1.Please try follwing this AR#68521 and let me know Sytem controller was responsive and didnt got stuck.

2. If Step 1 failed, install USB UART Driver version 6.7 on your PC.

  Note : 6.7 driver version is not officially supported in windows 10, but still you install, it works fine.

3. Even if step 2 fails, try changing the cable and share the result and if you have another board try the same with same cable.

4. If step 3 fails, there is issue with your board please file a devsys RMA SR.

 

Regards,

Deepak D N

------------------------------------------------------------------------------------

Please reply or give kudo or mark it as an Accepted Solution.

-------------------------------------------------------------------------------------

 

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------
0 Kudos
Visitor greg_soe
Visitor
416 Views
Registered: ‎03-04-2019

Re: VCU108 System Controller startup hanging

I do have another board and it behaves properly, so drivers/cables/etc are fine, looks like a hardware issue.

0 Kudos
Xilinx Employee
Xilinx Employee
404 Views
Registered: ‎06-06-2018

Re: VCU108 System Controller startup hanging

Hi @greg_soe ,

Since you are claiming that "I do have another board and it behaves properly, so drivers/cables/etc are fine".

yes there is hardware issue.

Please go ahead and file Devsys RMA case if your board is under 90 days warranty.

 

If it is out of warranty: 

Whizz Systems are our contract manufacturer and official Xilinx Design Partner.

They are best placed to repair Xilinx Development Systems Products (Boards and Kits) at the cost of the customer.
Please use the following Whizz Systems contact:
 
Regards,
Deepak D N
-------------------------------------------------------------------------------------------------------------
Please reply or Give kudo or Accept as a Solution.
-------------------------------------------------------------------------------------------------------------

 

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------