UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
123 Views
Registered: ‎06-21-2017

VCU118 lwip echo

Hello 

I am using Microblaze Example design on vivado to test the lwip echo server.

I am not able to run echo server on VCU188 microblaze example design. 

 

i have read here that this is a know issue. 

https://www.xilinx.com/support/answers/68277.html

so i also made the design ( shown below) on one of the latest versions  i.e. vivado 2018.3.  it also doesnt work on this version. 

 

i read on the forum that i have to disable, autonegotiation, and fix to speed in lwip BSP settings. i also did it. 

and i also didnt work (console output is shown below). 

 

Could you please guide me how to make it work ? 

 

Best Regards

Rizwan

 

 

 

block design 

MICROBLAZE_ethernet.png

 

 

console output 
-----lwIP TCP echo server ------
TCP packets sent to port 6001 will be echoed back
link speed: 100
Ethernet Link down
link speed: 100
Ethernet Link up
Ethernet Link down
link speed: 100
Ethernet Link up
Ethernet Link down
DHCP Timeout
Configuring default IP of 192.168.1.10
Board IP: 192.168.1.10
Netmask : 255.255.255.0
Gateway : 192.168.1.1
TCP echo server started @ port 7
link speed: 100
Ethernet Link up
Ethernet Link down
link speed: 100
Ethernet Link up
Ethernet Link down
link speed: 100
Ethernet Link up
Ethernet Link down
link speed: 100
Ethernet Link up
Ethernet Link down
link speed: 100
Ethernet Link up
Ethernet Link down
link speed: 100

0 Kudos