cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
stefanpopa92
Visitor
Visitor
772 Views
Registered: ‎05-15-2017

VCU128 Built In Test fails

Hello, 

I just purchased a VCU128 board and I followed the xtp535_vcu128 setup procedure. Next, I tried the built-in test by following the procedure described in xtp528_vcu128. As you can see in the attached image, the board fails the Ping, FMC LVDS and the UART1 test. I am using a Windows 10 machine and Vivado 2019.1. By accessing the System Controller application through Teraterm, I was able to pass all the available tests. Can you describe what those failing tests are doing? Does my board have problems? Please, help me!

test_with_default_sn.png

Thank you!

Tags (2)
0 Kudos
4 Replies
stefanpopa92
Visitor
Visitor
731 Views
Registered: ‎05-15-2017

@anatoli Sorry for bothering you, I saw you that you answered a similar question regarding the VCU128 board (https://forums.xilinx.com/t5/Xilinx-Evaluation-Boards/Problem-about-System-Controller-GUI-of-VCU128-board/td-p/1122764). Can you please provide some insight regarding this problem. Thank you very much!

0 Kudos
anatoli
Moderator
Moderator
655 Views
Registered: ‎06-14-2010

Hello @stefanpopa92 ,

Normally, Ping, IBERT, QSFP, FMC, and others will fail if the board is not setup right.

Based on the screenshot, it looks like UART is one of the test that is failing.

At the time of the test, have you had teraterm opened, as it normally uses one of the COM ports, so there is a possibility that the port that was selected by Board UI was already occupied by teraterm and hence this failed then.

Have you tried navigating to File->Change System Controller Port, and changing this to another port?

Please give this a try and see if this helps.

If not, please attach the log file of the runs, for examination.
For the UART failed test, let's see if an error log reports "COM PORT NOT FOUND", which would normally indicates a UART driver issue.
Or again, could be COM PORT selection problem. 

Anyhow, send us a copy of the LOG showing the text of the failure.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos
stefanpopa92
Visitor
Visitor
634 Views
Registered: ‎05-15-2017

Hello @anatoli ,

Thank you very much for your response.

At the time of the test, teraterm was closed. In Device Manager, when I connect the board to the computer through the USB connector, three new COM port appear (4, 5, 6). Separately, I was able to connect through Teraterm to COM4 and access the IPI test (xtp530_vcu128). I did not get any response on COM 5 and 6. All tests passed except the clocking one, which complained about the lack of an SMA ref clock since I did not provide one.

Yes, I tried all three COM ports through File->Change System Controller Port. 

I attach a log file for the UART test.

Thank you,

Stefan Popa

anatoli
Moderator
Moderator
493 Views
Registered: ‎06-14-2010

Hello @stefanpopa92 ,

Thanks for the info.

I can see you've selected Board: VCU128_PROD

You should be running the top level BoardUI.exe, not the production test. The production test has additional tests in it that need additional hardware.

Do you see the same failures with VCU128 (and VCU128_PROD)?

Ensure that no other Terminal program is connected to the VCU128’s COM ports while the Board Interface Test is running.

Also, please check this AR in relation to the PING test: https://www.xilinx.com/support/answers/72257.html

Hope this helps.

Kind Regards,
Anatoli Curran,
Xilinx Technical Support
------------------------------------------------------------------------------------------------

Don’t forget to reply, kudo, and accept as solution.

If starting with Versal, take a look at our Versal Design Process Hub and our
Versal Blogs

------------------------------------------------------------------------------------------------
0 Kudos