UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Explorer
Explorer
9,358 Views
Registered: ‎05-12-2010

Virtex 6 USB to UART hyper terminal settings

Jump to solution

Hi,

      I am using Virtex 6 ML 605 connectivity kit,I am trying to display some messages on hyperterminal but it's not being displayed,does any one know the correct hyperterminal settings when using USB to UART display data on hyperterminal.

 

Thanks,

mahesh

0 Kudos
1 Solution

Accepted Solutions
Visitor kzietlow
Visitor
11,716 Views
Registered: ‎08-21-2010

Re: Virtex 6 USB to UART hyper terminal settings

Jump to solution

The driver should load once you power up the ML-605.

The USB cable goes into the upper USB port on the left side of the board, the lower one is for JTAG.

If the driver doesn't load properly, you should see a USB device with a question mark in the device manager...

Klaus

 

View solution in original post

0 Kudos
8 Replies
Visitor kzietlow
Visitor
9,353 Views
Registered: ‎08-21-2010

Re: Virtex 6 USB to UART hyper terminal settings

Jump to solution

First of all you have to select the Silicon Labs CP210x driver as your com port.

(You did install the driver, didn't you? It's on the memory stick that comes with the ML-605)

The port settings you see in the device manager or are setting in Hyperterm are for the link between the USB bridge and the FPGA, so they depend on what settings you need from the FPGA side...

If you are using one of the sample programs, look at the user guide.

The BIST program for example uses 9600 baud 1 start 1 stop no parity.

Klaus

 

 

0 Kudos
Explorer
Explorer
9,347 Views
Registered: ‎05-12-2010

Re: Virtex 6 USB to UART hyper terminal settings

Jump to solution

Thanks for the reply,I have installed the driver but I don't see it in my ports under device manager ,I just created a program using xps( for testing memory and printing pass and fail) just wanted to know whether the same settings apply when RS-232 was being used instead of USB-UART cable

 

Thanks,

Mahesh

0 Kudos
Visitor kzietlow
Visitor
11,717 Views
Registered: ‎08-21-2010

Re: Virtex 6 USB to UART hyper terminal settings

Jump to solution

The driver should load once you power up the ML-605.

The USB cable goes into the upper USB port on the left side of the board, the lower one is for JTAG.

If the driver doesn't load properly, you should see a USB device with a question mark in the device manager...

Klaus

 

View solution in original post

0 Kudos
Explorer
Explorer
9,322 Views
Registered: ‎05-12-2010

Re: Virtex 6 USB to UART hyper terminal settings

Jump to solution

Thanks Klaus,I was using wrong port the driver installs itself as COM3 and I was using COM1.

 

Thanks again,

mahesh

0 Kudos
Visitor t.michal
Visitor
8,123 Views
Registered: ‎11-24-2011

Virtex 6 USB to UART problem

Jump to solution

Hi

If I power on my ML-605 board and I connect usb uart to computer, nothing happened.

I can't see any new device in device manager. It look like USB uart doesn't work.

Is there any switch or jumper to start usb uart work?? 

Or other way how to test status of uart.

The board is new and I just take her out from package.

Thanks for answer

Michal

0 Kudos
Moderator
Moderator
8,118 Views
Registered: ‎08-10-2007

Re: Virtex 6 USB to UART problem

Jump to solution

t.michal,

 

Check that you are using the USB UART port on the ML605, not the USB JTAG port.

If you change the USB cable to the other one in the box, does that make a difference?

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Visitor dcastropala
Visitor
8,001 Views
Registered: ‎03-21-2012

Re: Virtex 6 USB to UART problem

Jump to solution

Hello! i had some problems with my ML605 Embedded Kit.
I try to used for first time, my Virtex-6 FPGA ML605 Embedded Kit. I followed the instructions for the GETTING STARTED WITH THE VIRTEX-6 FPGA ML605 EMBEDDED KIT MANUAL (the Communicating with the ML605 USB-UART stage).

 

I followed the next instructions:
Communicating with the ML605 USB-UART

Installing the USB-UART driver
1. Execute the installer for the Silicon Labs USB-UART Virtual COM Port (VCP) driver from the Drivers_and_Tools folder   on the USB drive shipped with the ML605
Embedded Kit: Drivers_and_Tools\CP210x_VCP_Win2K_XP_S2K3.exe
2. Follow the installer instructions. Restart the computer when instructed to do so.

Connecting to the ML605 UART
1. Connect a USB Type-A to Mini-B 5-pin cable between the ML605 USB-UART connector (J21) and the host computer.
2. Power on the ML605 Evaluation Board if it is not already powered on.

Configuring the Host Computer
1. Right-click on My Computer and select Properties. Select the Hardware tab. Click on Device Manager.
2. Expand the Ports (COM & LPT) entry as shown in Figure 20. This shows the COM port assigned to the Silicon Labs CP210x USB to UART bridge. This is the COM port to use in the serial communications program

 

3. If using TeraTerm as the serial communications utility program, right-click on theSilicon Labs CP210x USB to UART bridge and select Properties.

a. Click on thePort Settings tab and then click Advanced.

b. Set the COM port to an open COM port setting from COM1 to COM4. Note thatthe COM port setting for your system may not be the one shown in (Figure 21)-

 

4. Click OK to exit all open windows.

 

Testing the USB-UART Driver Installation

1. Start a serial communication program such as HyperTerminal or TeraTerm on the Host

PC with the following settings:

• Baud Rate:9600

• Data Bits:8

• Parity:None

• Stop Bits:1

• Flow Control:None

2. Set the SystemACE DIP switches shown in

Figure 2 as listed in Table 2.

Table 2, show this for Switch S1:

---DIP Switch----Switch Position----

         1                     off

         2                     off

         3                     off

         4                     on

 

3. Press the SYS ACE RESET button (SW3) shown in Figure 22 to re-load the

Benchmarking Demo. Make sure the CompactFlash (CF) card is still inserted.

 

4. After a lapse of 1 to 5 seconds, the output shown in Figure 23 should be displayed on the serial communication window.

The Silicon Labs USB-UART Virtual COM Port (VCP) driver has now been installed.

 

BUT ALWAYS THE LED J69 (SYSTEM ACE ERROR LED) is set in "ON", this indicate, i had some problem with the configuration set, but i do not Know, what is the problem?

Maybe could be the configuration of the jumpers

or the CompactFlash?

Can you help me!

0 Kudos
Instructor
Instructor
7,994 Views
Registered: ‎07-21-2009

Re: Virtex 6 USB to UART problem

Jump to solution

Please start a new thread to discuss your new and unrelated topic.

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
0 Kudos