UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie fpgaj
Newbie
5,804 Views
Registered: ‎10-04-2007

XUP-V2P: Only USB 1.1

Hello,

I'm working with a new xup rev. 04 board: Whenever I connect the
integrated USB Platform cable I only get USB full speed (1.1) although
I need the faster USB 2.0 connection.

I tried 4 different machines, 3 different operating systems (VIsta,
WinXP SP2, Ubuntu) even switched the USB A-B cable -- various
combinations tried. The XUP board connects with 1.1, while in
each and every case my Spartan 3E starter kit connects with USB 2.0.

The vendor ids:

  Spartan3E : ID 03fd:000d Xilinx, Inc.
  xup-v2p:       ID 03fd:0009 Xilinx, Inc.


I could post the usb endpoint configuration as reported by linux, but I
cross checked with the Cypress EZ USB datasheet, and the USB
1.1 configuration for the xup looked like the one in the Cypress datasheet,
when cypress decides it must do usb 1.1.

Any ideas how to proceed?


   j.

0 Kudos