UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Observer kranthi018
Observer
157 Views
Registered: ‎07-02-2019

Xilinx Platform cable USB-2 not detected through vivado, when trying to program Zed board

We are trying to connect the Xilinx platform cable USB to the Zed board, Through vivado, JTAG chain initialized and shown TCK pin default frequency as 6MHZ, but device is not detected , not shown any ID.

We found in the Device Manager but found no device found , we set the configuration settings "0000" that is standard JTAG mode, and measured the voltages across TDI,TDO, TMS, TCK  all are <=3.3V, 

We captured the Signals in the Oscilloscopes and here by attaching all the waveforms and measured voltages across the pins

0 Kudos
1 Reply
Xilinx Employee
Xilinx Employee
106 Views
Registered: ‎06-06-2018

Re: Xilinx Platform cable USB-2 not detected through vivado, when trying to program Zed board

Hi @kranthi018 ,

Which version of Vivado and ISE you are using? And also share the OS details.

Since ZedBoard Documents are not availble with us. I can't comment more on Board hardware.

Since you are getting "ERROR: [Labtools 27-2269] No devices detected on target " Message in Tcl Console of vivado, Probable reasons for failure are:

>> Cable driver issue : You can reinstall Platform Cable II by referring this AR#54381  and if you are JTAG, then you can try reinstalling JTAG Driver by referring this AR#59128 .

>> If power issue is there in your ZedBoard, then Board may not get detected. You need to ensure that Board has no power issue. 

>> Ensure you are using Supported Vivado/ISE for the FPGA present in Zed Board and also Supported OS for Corresponding Viivado/ISE version.

>> Ensure you have added Board files to Vivado.

>> Try reducing JTAG frequency to 3MHz and try detecting the Device.

Regards,

Deepak D N

----------------------------------------------------------------------------------

Please Kudo and Accept as a Solution, If it helps.

-----------------------------------------------------------------------------------

Regards,
Deepak D N
---------------------------------------------------------------------------
Please Kudo and Accept as a Solution, If it helps.
---------------------------------------------------------------------------
0 Kudos