cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer
Observer
516 Views
Registered: ‎12-03-2018

ZC706 Flash error

I have a ZC706 board which I am trying to do some sanity checks on. I seem to have an issue programming QSPI Flash. I have tried the zc706 pcie example and the zc706_restore_flash example designs. For both these xilinx provided designs, run the "program_dual_qspi.bat" batch file on my windows machine, and get the following error message:

C:\zc706_restore_flash>call C:\Xilinx\SDK\2018.3\bin\program_flash -f C:\zc706_r
estore_flash\BOOT.mcs -offset 0 -flash_type qspi_dual_parallel

****** Xilinx Program Flash
****** Program Flash v2018.3 (64-bit)
**** SW Build 2405991 on Thu Dec 6 23:38:27 MST 2018
** Copyright 1986-2018 Xilinx, Inc. All Rights Reserved.


WARNING: Failed to connect to hw_server at TCP:localhost:3121
Attempting to launch hw_server at TCP:localhost:3121

Connected to hw_server @ TCP:localhost:3121
Available targets and devices:
Target 0 : jsn-JTAG-SMT2-210251A5333A
Device 0: jsn-JTAG-SMT2-210251A5333A-23731093-0

Retrieving Flash info...

Initialization done, programming the memory

ERROR: Flash Operation Failed

Press any key to continue . . .

 

I have tried using the Platform USB cable with SW 4 settings "10" and digilent USB-to-JTAG cable with SW4 settings "01". In both cases, the cable detection and device detection happens. Though I am not sure if the JTAG scan should see more than 1 device. 

The SW11 settings are set for JTAG boot. I am desperate to get past this problem since its been going on for a bit and I can't seem to get the service access portal to connect me to a dedicated engineer.

 

Chintan

 

0 Kudos
1 Reply
Highlighted
Moderator
Moderator
444 Views
Registered: ‎04-12-2017

Re: ZC706 Flash error

Hello @chintan_tag

can you manually try programming the MCS file provided along with the flash restoration design ?

The batch file you are running should eventually call the 2015.4 version of VIVADO hardware manager which can cause this issue.

Thank you

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos