cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
xilikarol
Observer
Observer
1,165 Views
Registered: ‎09-20-2018

ZCU-102 with NVMe SSD

Jump to solution

Hello everyone !

I followed the 14 min video : https://forums.xilinx.com/t5/Xcell-Daily-Blog-Archived/New-14-minute-video-shows-you-how-to-set-up-Zynq-UltraScale/ba-p/759423

and run into a problem : "AFTER booting the system from SD-card, logging in and giving the "lspcie -vvv" command I can not see the NVMe part of the command's output

(see attached pic). e.g. I do not see the "Kernel driver in use : nvme".

I do not see the nvme in the /dev/ either. I followed the video pretty rigorously, the only differences were due to different Vivado/Petalinux versions.

I had to use : Vivado 2018.3 / Petalinux 2018.3 running on a HW-Z1-ZCU-102 Rev.1.1. The SSD is a Samsung 970EVO in the onboard PCIe slot P1.

Due to the different versions of Petalinux (in video ver. 2016.3) I had different "choices" in the petalinux-configure -c rootfs ( I was not able to find and select the

libblkdid1, libfdisk1,libmount1,libbuuid1) and in the petalinux-configure -c kernel I had more NVME choices ( but I selected the" NVM Express block device" only as in the video).

But despite all that, I can not "see" and access the NVMe device ...

Any idea where the "bug" is in ?

Thanks in advance for your support.

lspci_output.PNG
0 Kudos
1 Solution

Accepted Solutions
xilikarol
Observer
Observer
1,101 Views
Registered: ‎09-20-2018

Well, the solution was to upgrade the whole toolset (Vivado,SDK,Petalinux) to version 2019.1 and it works now.

I suspect, that the 2018 version has a "problem".

This link : https://github.com/Xilinx/PYNQ/issues/767

pointed me into the right direction.

Best regards,

KT

View solution in original post

1 Reply
xilikarol
Observer
Observer
1,102 Views
Registered: ‎09-20-2018

Well, the solution was to upgrade the whole toolset (Vivado,SDK,Petalinux) to version 2019.1 and it works now.

I suspect, that the 2018 version has a "problem".

This link : https://github.com/Xilinx/PYNQ/issues/767

pointed me into the right direction.

Best regards,

KT

View solution in original post