UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Explorer
Explorer
902 Views
Registered: ‎05-22-2008

ZCU102 XAPP1305 10G Ethernet Reference Design Versioning

 

I have a ZCU102. I am trying to build the 10G Eth PL reference design (XAPP1305). My Vivado installation is 2018.1. 

 

When I try to build the design using the included script, it errors out because "This script was generated using Vivado<2017.3> and is being run in <2018.1> of vivado. 

 

Does anyone know if/when Xilinx might update the reference design for 2018.1? Or has anyone successfully hacked up the tcl scripts successfully?

 

I went into the script file that checks the version, pl_eth_10g_bd.tcl, and changed the version to 2018.1 and reran. I then get the equivalent of "can't find ethernet 2.3" I fix that and rerun, and then i get "zynq_ultra_ps_e:3.1 is not supported...blah blah blah

 

I don't have the 20G of disk space to install Vivado2017.3, so responses like "you should install 2017.3" aren't particularly helpful

0 Kudos
2 Replies
Moderator
Moderator
840 Views
Registered: ‎06-05-2013

Re: ZCU102 XAPP1305 10G Ethernet Reference Design Versioning

Hi,
It is always recommended to use the same version of Vivado in which XAPP is developed. Once the design is ready you can open the design in 2018.1. These errors are mostly due to the IP versions mismatches.

Thanks
Harshit
-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Explorer
Explorer
820 Views
Registered: ‎05-22-2008

Re: ZCU102 XAPP1305 10G Ethernet Reference Design Versioning

I know it's recommended to use the same version. This XAPP is built in 2017.3 which is currently on Xilinx' website in the Archive folder. And per the verbiage there " Archives Downloads are not maintained. We strongly recommend using the latest releases available."

 

I found the disk space to install the old version, but strictly speaking 2017.3 isn't supported on CentOS 7.4. It seems to work, but if it didn't I assume the recommendation would be to downgrade my OS?

0 Kudos