UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Participant petr_
Participant
252 Views
Registered: ‎02-26-2013

ZCU102 cut off DDR4 power after SCU update

Hi,

 

I have strange problem with ZCU102 board. I have two these boards, a in the one I updates SCU firmware to get it work with SCUI. After that, the board sometimes cut DDR power when it loading Uboot SPL. If I leave the board powered off for some hours, it's boot normally. In the second board with older SCU firmware, this problem never occurred. It's possible to downgrade the SCU firmware?

0 Kudos
2 Replies
Moderator
Moderator
233 Views
Registered: ‎04-12-2017

Re: ZCU102 cut off DDR4 power after SCU update

Hello @petr_,

 

what is the revision of your board ?

Are you connecting any FMC card on board ?

 

SCUI firmware should not affect the DDR4 power at all.

From the power section of SCUI please check if all the powers are on optimum level and then make sure all the status LEDs on board are correctly lit after power on.

 

Please refer UG1182 to understand the power levels and the nomenclature for all status LEDs.

 

You cannot revert back to older version SCUI firmware.

 

Thank you.

 

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Highlighted
Participant petr_
Participant
225 Views
Registered: ‎02-26-2013

Re: ZCU102 cut off DDR4 power after SCU update

PS DDR led and PS DDR VTT led switch off after 1-2 seconds after board is powered on. Only, if SD card with firmware inserted. 

I try to set J56 switch on the 3-4 position, no effect. Also DDR DC-DC converter output voltage is measured, it's zero in this case.

It seems the converter is killed via I2C.

 

Does SCU do anything itself after Zynq reset is de-asserted? It seems to some I2C communication collision between SCU and Zynq. 

0 Kudos