cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Observer
Observer
450 Views
Registered: ‎01-24-2011

ZCU102 ds47, ds46 & ds6 remain unlit at power-up

Jump to solution

I have several ZCU102 boards. One of them has started misbehaving. When I power it up (with no FMC boards connected), LEDs ds46 (SYSCTLR 1), ds47 (SYSCTLR 0) & ds6 (VADJ_FMC) remain unlit.

FWIW I've (successfully) reprogrammed the power regulators using the Maxim PowerTool, but this has had no effect.

I would appreciate any advice as to how to proceed. Thanks!

Tags (1)
0 Kudos
Reply
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
236 Views
Registered: ‎06-25-2020

Hi Roddy,

Since the power reprogramming could not fix the issue it indicates hardware failure with the power rails.

If the board is under 90 days warranty please file a RMA SR with Xilinx to get the board replaced or If the board is out of warranty we would advise you to contact Whizz Systems who are our contract manufacturer and official Xilinx Design Partner. They are best placed to repair Xilinx Development Systems Products (Boards and Kits) at the cost of the customer.

Below are their contact details-

info@whizzsystems.com

http://www.whizzsystems.com/contact-us/

 

Best Regards,

Vatsal

View solution in original post

7 Replies
Xilinx Employee
Xilinx Employee
399 Views
Registered: ‎06-25-2020

Hi,

Please check the SCUI voltage readings and match them against the default readings.

https://www.xilinx.com/member/forms/download/design-license.html?cid=cd76e6f1-932f-454e-a8aa-04114f041b1f&filename=xtp433-zcu102-system-controller-c-2019-1.pdf

Also share the Screenshots (if you have taken any) of the power reprogramming procedure. 

Please check the power reprogramming pdf to confirm if all the conditions are met before and after the power reprogramming.

https://www.xilinx.com/Attachment/ZCU102_Power_Controllers_Reprogramming_Steps.pdf

Best Regards,

Vatsal Tripathi

PAE, XHD

0 Kudos
Reply
Observer
Observer
386 Views
Registered: ‎01-24-2011

Hi Vatsal

I didn't take screenshots when reprogramming the regulators, but

(a) please find attached screenshots from the Powertool output now

(b) I'm confident that I followed the instructions correctly and that the all the conditions were met before and after programming.

I should have said this in the first post: I am unable to connect to the SCUI. Nothing appears on the relevant serial port on power-up. (Note that I have another ZCU102 for which I *can* connect, so I'm familiar with the procedure -- I'm confident there is nothing wrong with my cables or serial port settings.)

Should I consider reflashing the MSP430? (using the procedure at 1.4.1 of https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842495/Zynq+UltraScale+MPSoC+Power+Advantage+Tool+part+2+-+Installing+the+Pre-Built+Power+Advantage+Tool)?

Thanks for your help!

Roddy

powertool_part1.png
powertool_part2.png
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
356 Views
Registered: ‎06-25-2020

Hi,

Please check and update the firmware version of the board.

Follow XTP433 https://www.xilinx.com/support/documentation/boards_and_kits/zcu102/2019_1/xtp433-zcu102-system-controller-c-2019-1.pdf and see if helps with the SCUI issue.

If power reprogramming is unable to solve the issue it may indicate some hardware issue with the power rails.

Best regards,

Vatsal

0 Kudos
Reply
Observer
Observer
351 Views
Registered: ‎01-24-2011

Hi Vatsal

I am unable to update the firmware of the board using the procedure in XTP433 because I cannot connect to the system controller on the serial port. (Please note that this is for this board only -- I can connect on other ZCU102 boards.)

Shall I try flashing the MSP430 using a MSP-FET dongle cable?

Thanks!

Roddy

0 Kudos
Reply
Xilinx Employee
Xilinx Employee
333 Views
Registered: ‎06-25-2020

Hi Roddy,

Yes please go ahead. Let us know if it helped.

Best Regards,

Vatsal

0 Kudos
Reply
Observer
Observer
277 Views
Registered: ‎01-24-2011

Hi Vatsal

I bought the MSP430 flasher dongle and was successfully able to rewrite the MSP430's flash using the instructions at https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842495/Zynq+UltraScale+MPSoC+Power+Advantage+Tool+part+2+-+Installing+the+Pre-Built+Power+Advantage+Tool Please see attached screenshot for confirmation of success.

However, sadly DS46 & DS47 still remain unlit; I cannot access the SCUI and the board does not boot. (Reminder -- all the power rails are working, so this is not the problem.)

Please let me know if you have any further ideas or if rather you think the board is damaged.

Thanks!

Roddy

 

zcu102_msp430_flash.png
0 Kudos
Reply
Xilinx Employee
Xilinx Employee
237 Views
Registered: ‎06-25-2020

Hi Roddy,

Since the power reprogramming could not fix the issue it indicates hardware failure with the power rails.

If the board is under 90 days warranty please file a RMA SR with Xilinx to get the board replaced or If the board is out of warranty we would advise you to contact Whizz Systems who are our contract manufacturer and official Xilinx Design Partner. They are best placed to repair Xilinx Development Systems Products (Boards and Kits) at the cost of the customer.

Below are their contact details-

info@whizzsystems.com

http://www.whizzsystems.com/contact-us/

 

Best Regards,

Vatsal

View solution in original post