UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
345 Views
Registered: ‎09-18-2018

ZCU104 is actually SD2.0 instead of SD3.0?

Jump to solution

Hi all,

Just ran into a confusing situation. 

On ZCU104's documentation (ug1267), it claims that ZCU104 supports SD1-3.0; but this conflicts with two things.

1. It conflicts with Vivado default setting, Vivado says “MIO45-51" and SD 2.0 

Capture2.PNG

2. It conflicts with the shcematic, MIO39-44 are not connected, thus SD 3.0 should not be possible. More over, does SD2.0 also requries level shifter?

Capture.PNG

Also attached, Vivado SD 3.0 interface selection:

Capture3.PNG

What is going on?

Thanks ahead.

0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
279 Views
Registered: ‎09-01-2014

Re: ZCU104 is actually SD2.0 instead of SD3.0?

Jump to solution
UG1085 mentions that 2.0 mode only supports 3.3V for the I/Os while ZCU104 uses 1.8v MIO setting.

View solution in original post

0 Kudos
4 Replies
Xilinx Employee
Xilinx Employee
308 Views
Registered: ‎09-01-2014

Re: ZCU104 is actually SD2.0 instead of SD3.0?

Jump to solution
Yes, as you observed. ZCU104 doesn't use an SD3.0-compliant voltage level-translator. it doesn't work on SD3.0.
Vivado Board present is no problem to set as SD2.0.
Contributor
Contributor
300 Views
Registered: ‎09-18-2018

Re: ZCU104 is actually SD2.0 instead of SD3.0?

Jump to solution
Thanks, that clears things up!
0 Kudos
Contributor
Contributor
291 Views
Registered: ‎09-18-2018

Re: ZCU104 is actually SD2.0 instead of SD3.0?

Jump to solution

Although, there are a couple of confusion I still have:

1. Why does boot mode 1110 (SD1-LS) still works without the necessary pin connected, and

2. Why does boot mode 0101 (SD1-2.0) does not work, since it uses essentially the same pin as the zcu104 SD pin?

 

 

0 Kudos
Xilinx Employee
Xilinx Employee
280 Views
Registered: ‎09-01-2014

Re: ZCU104 is actually SD2.0 instead of SD3.0?

Jump to solution
UG1085 mentions that 2.0 mode only supports 3.3V for the I/Os while ZCU104 uses 1.8v MIO setting.

View solution in original post

0 Kudos