cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
493 Views
Registered: ‎06-21-2018

ZCU106Targeted Reference Design - DM4 not running

Jump to solution

Hello,

 

I am testing the ZCU106 evaluation kit with the Targeted Reference Design available and I am having some problems to generate the bitstream when running the Design Module 4 (DM4) - Full-fledged VCU TRD. The other three Design Modules work perfectly but that one (the one that encompasses all the features and therefore the most interesting for evaluation purposes) does not. It fails when running the "Out-of-Context Modules Runs" task and 48 error messages like the following one are generated:

 

[Synth 8-439] module 'zcu106_vcu_trd_v_frmbuf_wr_0_2_v_frmbuf_wr' not found ["d:/Xilinx/zcu106/pl/vcu_trd_proj/zcu106_vcu_trd.srcs/sources_1/bd/zcu106_vcu_trd/ip/zcu106_vcu_trd_v_frmbuf_wr_0_2/synth/zcu106_vcu_trd_v_frmbuf_wr_0_2.v":269]

 

I suppose there are some modules missing and I thought that maybe I should run the other three Design Modules included in the Targeted Reference Design before running this one just in case there are some dependencies but it was not the case and I still get the same errors. Does anyone know what is going on? I had a look at the DM4 Xilinx Wiki article (here) but I could not find any solution for this problem.

 

Thanks in advance, best regards,

Javichu

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Contributor
Contributor
514 Views
Registered: ‎05-14-2018

Javichu,

 

Are you building the designs under a Windows or Linux operating system? It looks like you are using Windows. The designs generate really long path names. Some are too long for Windows. Linux has no restriction. Under Windows the design might build if you move the project directory 'vcu_trd_proj' to the top of the D: drive. If that fails try shortening the project directory name from 'vcu_trd_proj' to 'proj'.

 

There are other things to try in this answers record:

 

Steve.

View solution in original post

1 Reply
Highlighted
Contributor
Contributor
515 Views
Registered: ‎05-14-2018

Javichu,

 

Are you building the designs under a Windows or Linux operating system? It looks like you are using Windows. The designs generate really long path names. Some are too long for Windows. Linux has no restriction. Under Windows the design might build if you move the project directory 'vcu_trd_proj' to the top of the D: drive. If that fails try shortening the project directory name from 'vcu_trd_proj' to 'proj'.

 

There are other things to try in this answers record:

 

Steve.

View solution in original post