UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Observer xiaochh
Observer
5,548 Views
Registered: ‎05-06-2008

download problem with sp601 designs

Jump to solution

 

  Hello,eveyone.

  

  I  have got a sp601 kit., installed ise11.3 and CP210x USB to UART Bridge driver (installed on line).

  Lunckly ,follow the 《Getting Started with the Diagnostic FLASH Demo》 user guide ,I have passed all the Diagnostic Tests in the demo. and runned the Base System Reference design successfully.

 

  But ,i can't download my  bit file to the FPGA. the detail is :

 

  As the tool has not support spartan 6 design in BSB.

  SO ,I  created a simple BSB design with virtex 4 (the design just include one uart peripheral ), and then changed the hardware properties to "sptarten lx-16, 324 ,-2,",  also changed the  MHS and corresponding MSS, added ucf.

 

    Finally,This design  generate a bit file successfully. i download this bit file with impact tool in ise 11.3, but ,no print information printed to my HyperTerminal,however ,the software application is just the memory test or peripheral test applications auto generated by the bsb.

 

   I generated a bit file  with "uart test" software application in reference design   "SP601 Standalone Applications --rdf 0015  .. but no information printed on Hyper Terminal neither.

  

   my Terminal Port Settings as follows: 

        baud rate : 9600, Data bits : 8, Parity:  None, Stop bits : 1, and Flow control: None.

 

   and the  Diagnostic  Demo design (BIST) can print information correctly.So i think the uart can  work , 

 

   But why my bit file has no print ? neither did the bit file generated by SP601 Standalone applications provieded by XILINX ?

 

   Is there any problem with the download process ?

 

   Sincerely looking forward to your help.

   Thanks for your help.

 

0 Kudos
1 Solution

Accepted Solutions
Observer xiaochh
Observer
7,047 Views
Registered: ‎05-06-2008

Re: download problem with sp601 designs

Jump to solution
my download problem has resolved  ,Thanks ,mcgett!
0 Kudos
3 Replies
Xilinx Employee
Xilinx Employee
5,526 Views
Registered: ‎01-03-2008

Re: download problem with sp601 designs

Jump to solution
There are two USB ports on the SP601.  After downloading the design through the USB JTAG port did you then switch the cable to the USB UART port?
------Have you tried typing your question into Google? If not you should before posting.
Too many results? Try adding site:www.xilinx.com
Observer xiaochh
Observer
7,048 Views
Registered: ‎05-06-2008

Re: download problem with sp601 designs

Jump to solution
my download problem has resolved  ,Thanks ,mcgett!
0 Kudos
Visitor deepsece06
Visitor
4,037 Views
Registered: ‎04-09-2011

Re: download problem with sp601 designs

Jump to solution

Hi xiaochh

 

can u tell me how u have runned the Base System Reference design successfully as i am getting problem my jtag is not recognised and when i connected the ethernet and on setup/ network interface when i select only one option as it comes is broadcom netxtreme ethernet gigapet then it says on status that fpga not connected. i also could not open the MCS file given on the usb of xilinx. pls help...

0 Kudos