cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Visitor
Visitor
556 Views
Registered: ‎02-17-2020

flashing board ZCU102 revision1.1

Jump to solution

Hi,

We are using xilinx zcu102 revision 1.1 board . sdk 2018.3

we are not able to flash even simple hellowaord progam using JTAG.

I modified jumper settings as in one user guide for revision1.0   Please guide me to reslve this issue.

Any configurations should be doe

Thanks and Regards,

Subrahmaniam

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Xilinx Employee
Xilinx Employee
291 Views
Registered: ‎06-13-2018

Re: flashing board ZCU102 revision1.1

Jump to solution

Hello @subrahmaniam,

I'm glad to hear that you are able to run the "Hello World" example design.

Please close this Thread by accepting this as an "Accepted Solution".

 replaced xfsbl_ddr_init.c ,xfsbl_hooks.c and xfsbl_hooks.h from 72113.zip files . as per the document for New board configuration.  Still not able to flash tcp client program. please guide me in resolve this issue.

For this query, please create a new post on Embedded Software Development.

Regards,

Naveen

View solution in original post

14 Replies
Highlighted
Xilinx Employee
Xilinx Employee
530 Views
Registered: ‎11-05-2019

Re: flashing board ZCU102 revision1.1

Jump to solution

 

Hi @subrahmaniam 

 

I don't think this AR is relevant because you are using XSDK2018.3, but it might be a solution.

AR#71961 MPSoC ZCU102 and ZCU106 Evaluation Kits - DDR4 SODIMM change
AR#72113 MPSoC PS DDR - DDR4 training occasionally fails on ZCU102 and ZCU106 boards using newer DIMMs

 

Regards,

Ka2ki
Don't forget to reply, kudo, and accept as solution.

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
526 Views
Registered: ‎06-13-2018

Re: flashing board ZCU102 revision1.1

Jump to solution

Hello @subrahmaniam,

Please share the following details with us:

1. Are you facing this issue at time zero or after a period of usage on all the 3 boards?

2. Please share the Board Power GOOD LEDS Snapshot and also Board front side Snapshot at power ON.

3. Please go through this https://www.xilinx.com/support/answers/68386.html and confirm me that till step 4, all steps are passing or not ?

4. Ensure that you have correctly followed XTP435 completely. Mainly Ethernet Setup and clock Setup. Please confirm the same. 

5.  PS DDR4 depends on the new SODIMM Part on Board. Due to an End of Life notification from Micron Technology, Inc. the DDR4 SODIMM part on the ZCU106zc Evaluation Kit has changed. For more information please check AR-71961. For workaround please check 

You need to replace the FSBL source code file. Please check AR-72113. To work around this issue, you can replace the FSBL source code files with the attached .c/.h files in 72113-files.zip. this issue has been resolved in Vivado 2019.2

NOTE: This FSBL source file is only for Vivado 2018.3. Prior to Vivado 2018.3, customer needs to modify the DDR Configuration setting manually and then, they need to generate the FSBL source code File.

Please find the modified DDR configuration settings.

Capture.PNG

6. Please confirm that there is no Tera Term window opened on your PC. 

7. To check the health of the board perform BIST Test and share the results.

8. Which Vivado Version you are using?

Note : If BIST Test fails, perform  XTP434 - ZCU102 Restoring Flash Tutorial (v11.0) and again perform BIST Test and share the results.

Hope this information will help you. Looking forward to hearing from you.

Regards,

Naveen

---------------------------------------------------------------------------------------------

Please reply or give kudo or Accept as a Solution.

----------------------------------------------------------------------------------------------

0 Kudos
Highlighted
Visitor
Visitor
507 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

Thanks for your answer,

I am new to this xilinx board. it is at zero time. 

where should I do this ddr and clock configurations manually.

now able to flash.  but it is not consistancy.  some times able to debug.  some times some TCF error getting.

We run helloworld program not consistancy. but run some times .  I could ot find the problem.

Imported tcp project from demo applications . built but unable to debug Core r5_0 is running . when try to debug and it is not going to main or some times giving TCF errrors. please guide me.

Where should I replace FSBL code.

Thanks and regards,

K Subrahmaniam

 

0 Kudos
Highlighted
Visitor
Visitor
500 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

For fourth test , we are getting 7th led on and off for any switch testing , not getting clear idea.

Thanks and regards,

K Subrahmaniam

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
423 Views
Registered: ‎06-13-2018

Re: flashing board ZCU102 revision1.1

Jump to solution

Hello @subrahmaniam

Please share the complete snapshot of your board when power is ON.

I am assuming that you are following UG-1209, In Zynq MPSoC IP you need to modify these DDR settings under the tab DDR Configuration.

Regards,

Naveen 

 

0 Kudos
Highlighted
Visitor
Visitor
410 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

Please find the snapshot of board when power on.

Thanks and Regards,

K SUbrahmaniam1.jpg

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
395 Views
Registered: ‎06-13-2018

Re: flashing board ZCU102 revision1.1

Jump to solution

Hello @subrahmaniam,

Your board image is not clear. Can you please check, is your board is labeled with  0432055-05? If yes, you need to modify the DDR configuration settings. 

Regards,

Naveen 

0 Kudos
Highlighted
Visitor
Visitor
385 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi

where can we see that number 0432055-05  and where DDR window can be found.

REgards,

K SUbrahmaniam

0 Kudos
Highlighted
Visitor
Visitor
383 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

We are not using vivado,  sdk only.

Regards,

K Subrahmanam

0 Kudos
Highlighted
Visitor
Visitor
374 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

Yes it is 0432055-05 .  found on the sticker on the board.

please guide me where ddr configurations window can be found.

Thanks and regards,

K Subrahmaniam

0 Kudos
Highlighted
Visitor
Visitor
364 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

Yes it is 0432055-05-1920

We are using xilinx sdk 2018.3  .  vivado is not installed.

Please guide me where can I configure DDR . where can I find DDR configure window in xilinx SDK.

Thanks and regards,

K Subrahmaniam

0 Kudos
Highlighted
Xilinx Employee
Xilinx Employee
350 Views
Registered: ‎06-13-2018

Re: flashing board ZCU102 revision1.1

Jump to solution

Hello @subrahmaniam,

Please check https://www.xilinx.com/support/answers/72113.html.

 

Regrads,

Naveen 

0 Kudos
Highlighted
Visitor
Visitor
296 Views
Registered: ‎02-17-2020

Re: flashing board ZCU102 revision1.1

Jump to solution

Hi,

we are able to flash helloworld program. 

trying tcp client demo application  , it is showing memory  aborting error some times and 

in debug mode it is not going to main.

I replaced xfsbl_ddr_init.c ,xfsbl_hooks.c and xfsbl_hooks.h from 72113.zip files . as per the document for New board configuration.  Still not able flash tcp client program. please guide me in resolve this issue.

We have no vivado tool and have xilinx 2018.3

Thanks and Reards,

K Subrahmaniam

Highlighted
Xilinx Employee
Xilinx Employee
292 Views
Registered: ‎06-13-2018

Re: flashing board ZCU102 revision1.1

Jump to solution

Hello @subrahmaniam,

I'm glad to hear that you are able to run the "Hello World" example design.

Please close this Thread by accepting this as an "Accepted Solution".

 replaced xfsbl_ddr_init.c ,xfsbl_hooks.c and xfsbl_hooks.h from 72113.zip files . as per the document for New board configuration.  Still not able to flash tcp client program. please guide me in resolve this issue.

For this query, please create a new post on Embedded Software Development.

Regards,

Naveen

View solution in original post