UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Newbie fcuzzocrea
Newbie
196 Views
Registered: ‎07-19-2019

impact : Cable autodetection failed with spartan-3e evb (write cmdbuffer failed 20000015)

Hi

I'm using a Spartan-3E evb from digilent with Xilinx WebPack ISE 14.6 on Windows 10 home.  In the device manager the cable is correctly installed (connecting the board appears the Xilinx USB Cable element in green). When I attempt to connect with the cable using impact result is:

 

GUI --- Auto connect to cable...
INFO:iMPACT - Digilent Plugin: Plugin Version: 2.4.4
INFO:iMPACT - Digilent Plugin: no JTAG device was found.
AutoDetecting cable. Please wait.
*** WARNING ***: When port is set to auto detect mode, cable speed is set to default 6 MHz regardless of explicit arguments supplied for setting the baud rates
PROGRESS_START - Starting Operation.
Connecting to cable (Usb Port - USB21).
Checking cable driver.
Driver file xusbdfwu.sys found.
Driver version: src=1027, dest=1027.
Driver windrvr6.sys version = 10.2.1.0. WinDriver v10.21 Jungo (c) 1997 - 2010 Build Date: Aug 31 2010 x86_64 64bit SYS 14:14:44, version = 1021.
Cable PID = 0008.
Max current requested during enumeration is 74 mA.
write cmdbuffer failed 20000015.
write cmdbuffer failed 20000015.
Loopback test failed. Sent character = 00, Received character = 0E.
Cable connection failed.

 

How can I overcome ?

regards

0 Kudos
2 Replies
186 Views
Registered: ‎09-30-2011

Re: impact : Cable autodetection failed with spartan-3e evb (write cmdbuffer failed 20000015)

This is an odd issue. It sometimes appears when two applications are attempting to use the cable at the same time (say you mistakenly invoked iMPACT twice or have the SDK running or Chipscope running as well as iMPACT). Sometimes the issue just "goes away" when you unplug and then replug the cable. That's all I've got on this one.

0 Kudos
Xilinx Employee
Xilinx Employee
144 Views
Registered: ‎06-13-2018

Re: impact : Cable autodetection failed with spartan-3e evb (write cmdbuffer failed 20000015)

Hello @fcuzzocrea,

Xilinx does not officially support using Windows 8.1 or Windows 10 with ISE Design Suite.

 For the workaround please check the below link.

https://www.xilinx.com/support/answers/62380.html

https://www.xilinx.com/support/answers/30184.html

https://www.xilinx.com/support/answers/31254.html

Hope this information will help you.

Regards,

Naveen   

0 Kudos