cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
Observer
Observer
1,503 Views
Registered: ‎01-13-2010

Fifo Write Data Count == 2 after reset

Jump to solution

Hi, I used Vivado 14.7 and Fifo Generator 13.2 to generate native fifo, independent clocks BRAM, FWFT, 32bits r/w, 2048 words deep, reset pin, reset sync enabled, async reset, safety circuit,more accurate data counts. The fifo is for independent clocks, but right now the read/write clocks are the same clock

 

Both sim and actual hardware show the same: After a manual reset of the fifo, the write data count is 2 always. Why is that? Even in sim, where I can watch it come out of reset and ensure there's nothing going on the write enable I see this. The fifo works as I expect aside from this. Am I missing something fundamental? 

 

Thanks

 

 

0 Kudos
1 Solution

Accepted Solutions
Highlighted
Observer
Observer
1,640 Views
Registered: ‎01-13-2010

The answer to my question is in table 3-3 of the Fifo Generator doc PG057. This table shows that when read/write width ratio is 1:1 and More Accurate Data Count is enabled, then the empty fifo wr_data_count is 2. In other words, you NEVER will see the fifo report 0. 

 

Thus, the behavior is expected. 

View solution in original post

0 Kudos
3 Replies
Highlighted
Moderator
Moderator
1,465 Views
Registered: ‎08-08-2017

Hi @matttay

 

I believe you are using VIVADO 2017.4  (VIVADO 2014.7 is not exist). Please share the ILA capture depicting this 

behavior.

I will check the simulation at my end with the settings you have mentioned ,but it will be useful if you share the .xci to check the other 

parameters i.e Synchronization stages, ECC , output register  options .

 

--------------------------------------------------------------------------------------------------

Reply if you have any queries , Give Kudos and accept as solution

--------------------------------------------------------------------------------------------------

 

-------------------------------------------------------------------------------------------------------------------------------
Reply if you have any queries, give kudos and accept as solution
-------------------------------------------------------------------------------------------------------------------------------
0 Kudos
Highlighted
Observer
Observer
1,641 Views
Registered: ‎01-13-2010

The answer to my question is in table 3-3 of the Fifo Generator doc PG057. This table shows that when read/write width ratio is 1:1 and More Accurate Data Count is enabled, then the empty fifo wr_data_count is 2. In other words, you NEVER will see the fifo report 0. 

 

Thus, the behavior is expected. 

View solution in original post

0 Kudos
Highlighted
Moderator
Moderator
1,459 Views
Registered: ‎08-08-2017

Hi @matttay

 

Thank you for pointing this out.

Please mark your answer as accepted solution to close this thread.

-------------------------------------------------------------------------------------------------------------------------------
Reply if you have any queries, give kudos and accept as solution
-------------------------------------------------------------------------------------------------------------------------------
0 Kudos