cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
daby
Visitor
Visitor
380 Views
Registered: ‎05-04-2021

ORAN IF IP no packets observed at m_defm_data port

Hello,

We work on wireless-xorif repository. We connected 1 to m_defm_data_tready port in order to debug all ORAN packets.

We debugged s_eth and m_defm_data ports. m_defm_data port does not present any data port, though ORAN IP gets packets on_time (It is observed from " xorif-app -i -c 'get fhi_stats 0' ").

What are the possible reasons?

0 Kudos
4 Replies
xud
Xilinx Employee
Xilinx Employee
353 Views
Registered: ‎08-02-2007

@daby 

It's hard to say, so far I've seen a few possible reasons : 

1. The buffer is not set properly. even though you receive the packets within reception window, but not enough DL buffer so you can't get any output

2. The configuration doesn't match with the DL pcap. I've seen a case the BFP bitwidth doesn't match the one in pcap, and tready/tlast are not generated correctly (due to zero padding in Ethernet packets). In this case, radio head is in reception window but you can't see output.

Are you able to reproduce the issue in simulation, with pcap file? If so, I can have a close look at it.

Regards,

Xu

0 Kudos
daby
Visitor
Visitor
350 Views
Registered: ‎05-04-2021

@xud

I explained the issue wrong a bit. There are approximately 300 packets at m_defm_data port when O-DU transmits ORAN packets for the first time.

0 Kudos
xud
Xilinx Employee
Xilinx Employee
273 Views
Registered: ‎08-02-2007

@daby 

What happens after you received ~300 packets? The link was disconnected? Do you have ILA capture on the Ethernet interface after ~300 packets? 

0 Kudos
daby
Visitor
Visitor
268 Views
Registered: ‎05-04-2021

@xud 

We are not able to do hardware debug, so we do not have ILA capture. The link is stable after ~300 packets, and ORAN IP counters are still active. We observe that ORAN packets are coming from O-DU. However, no packets are in m_defm_data even packets are accepted by s_eth port.

0 Kudos