UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Contributor
Contributor
630 Views
Registered: ‎11-08-2018

Not able to run ml-suite on 1525 card

I am trying to do the following steps after ml-suite setup:

$ cd ml-suite/examples/classification

$ ./run.sh -p 1525 -t test_classify -k med -b 16

I am getting the following error:

Loading weights/bias/quant_params to FPGA...
ERROR: Failed to allocate A device memory
python: xblas.cpp:3163: void xblasLoadA(XBLASHandle&, int, const void*, const char*, XBLASConfig*, int): Assertion `ret' failed.
./run.sh: line 136: 31701 Aborted (core dumped) python test_classify.py --xclbin $XCLBIN_PATH/$XCLBIN --netcfg ./data/${MODEL}_${DSP_WIDTH}.json --fpgaoutsz $FPGAOUTSZ --datadir ./data/${MODEL}_data --labels ./synset_words.txt --xlnxlib $LIBXDNN_PATH --quantizecfg ./data/${MODEL}_${BITWIDTH}b.json --firstfpgalayer $FLAYER --images dog.jpg --PE $ACCELERATOR

 

Screenshot from 2018-11-29 17-23-08.png
0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
575 Views
Registered: ‎08-06-2007

Re: Not able to run ml-suite on 1525 card

Hi, Which version of the ml suite are you using right now? thanks, kamran
/k
0 Kudos
Contributor
Contributor
557 Views
Registered: ‎11-08-2018

Re: Not able to run ml-suite on 1525 card

Hi @kamrank,

I am using master branch of mlsuite.

Now, i am able to run the image classification.

I got the output as below, but whatever the input, the output of the image classification is same.

$ ./run.sh -p 1525 -t test_classify -k med -b 16

output:
make: Entering directory `/home/xpac/ml-suite/apps/yolo/nms'
cd ./nms_20180209 && make
make[1]: Entering directory `/home/xpac/ml-suite/apps/yolo/nms/nms_20180209'
make[1]: Nothing to be done for `all'.
make[1]: Leaving directory `/home/xpac/ml-suite/apps/yolo/nms/nms_20180209'
make: Leaving directory `/home/xpac/ml-suite/apps/yolo/nms'

Running:
Test: test_classify
Model: resnet50
Fpgaoutsz: 2048
Platform: 1525
Xclbin: overlay_1.xclbin
Kernel Config: med
Precision: 16
Accelerator: 0

[XBLAS] # kernels: 1
Linux:3.10.0-693.el7.x86_64:#1 SMP Tue Aug 22 21:09:27 UTC 2017:x86_64
Distribution: CentOS Linux release 7.4.1708 (Core)
GLIBC: 2.17
---
XILINX_OPENCL="/home/xpac/ml-suite/overlaybins/1525"
LD_LIBRARY_PATH="/home/xpac/ml-suite/overlaybins/1525/runtime/lib/x86_64/:/home/xpac/ml-suite/xfdnn/rt/xdnn_cpp/build/lib:/home/xpac/ml-suite/xfdnn/rt/lib:/home/xpac/ml-suite/ext/boost/lib:/home/xpac/ml-suite/ext/zmq/libs:/home/xpac/ml-suite/examples/classification"
---
CL_PLATFORM_VENDOR Xilinx
CL_PLATFORM_NAME Xilinx
CL_DEVICE_0: 0x1c97520
CL_DEVICE_1: 0x1c98e90
CL_DEVICES_FOUND 2, using 0
loading /home/xpac/ml-suite/overlaybins/1525/overlay_1.xclbin
[XBLAS] kernel0: kernelSxdnn_0
[XDNN] loading xclbin settings from /home/xpac/ml-suite/overlaybins/1525/overlay_1.xclbin.json
[XDNN] using custom DDR banks 2,2,1,1

[XDNN] kernel configuration
[XDNN] num cores : 2
[XDNN] dsp array width : 28
[XDNN] img mem size : 4 MB
[XDNN] version : 2.2
[XDNN] 8-bit mode : 0
[XDNN] Max Image W/H : 1023
[XDNN] Max Image Depth : 4095
[XDNN] Max Filter Depth : 0

Loading weights/bias/quant_params to FPGA...

After FPGA (20078.809977 ms)

After FC (1.541138 ms)

After Softmax (0.437975 ms)


---------- Prediction 0/0 for dog.jpg ----------
0.0010 - "n03657121 lens cap, lens cover"
0.0010 - "n07615774 ice lolly, lolly, lollipop, popsicle"
0.0010 - "n04356056 sunglasses, dark glasses, shades"
0.0010 - "n04597913 wooden spoon"
0.0010 - "n03759954 microphone, mike"


Success!