Don't have a Xilinx account yet?

  • Choose to receive important news and product information
  • Gain access to special content
  • Personalize your web experience on Xilinx.com

Create Account

Username

Password

Forgot your password?
XClose Panel
Xilinx Home
Reply
Newbie
zyfeier
Posts: 1
Registered: ‎08-14-2008

SPARTAN-3E usb cable driver

OS:Windows xp 

Hardware:SPARTAN-3E

Software:LabVIEW FPGA

 

The hardware can be identified , setup successfully, and the program passed compile. But when i run the programme, Windows prompts deathful error, which is that the windriver was outdated.

Newbie
rfox14
Posts: 1
Registered: ‎06-26-2011
0

Re: SPARTAN-3E usb cable driver

That makes two of us...

 

I am using the digilent Spartan E board and having communication errors.  I followed the installation instructions "getting started"  posted here https://lumen.ni.com/nicif/us/infolvfpgaxilsprtn/content.xhtml..  I have disabled all virus protection and make sure the Spartan E is not connected during install.  I have labview 2010, Xilinx 10.1, Xilinx 11.5, Compile Farm and the Spartan E driver.  Whither I make my own project or I use a NI example (ie shift.lvproj*) I get the following error:

 

Labview FPGA called another software component, and that component returened the following error:

 

Error Code:-310601

 

Ni-Cobs; unable to detect communication cable.

 

 

 

Please verify that the communication cable is plugged securely into your computer and target. Also verify that the appropriate drivers are installed.  

 

I have the Xilinx usb cable driver 2.0.0.1.  The driver file details is as follows:

 

File version   10.11 bulit by : winddk

Coprywright: Jungo confidential. copyright (c_ 2010 Jungo Ltd.

Digtal Signer:  Not digitally signed

 

I have verified that the driver is up to date and verified that the Spartan-3e can communicate with Impact (xilinx toolset for download of bit files). 

 

 

I have uninstalled and reinstalled Labview 2010, Xilinx 10.1, Xilinx 11.5, Compile Farm and the Spartan E drive to no avail.  I have done everything humanly possible.  I have been stuck on this error for days and cannot figure it out.  Please help me..

Expert Contributor
eteam00
Posts: 8,350
Registered: ‎07-21-2009
0

Re: SPARTAN-3E usb cable driver

I have not used the Labview software.  This ignorance notwithstanding, you are at the mercy of several players:

 

1.  Microsoft -- what version of Windows are you running?

 

2.  National Instruments -- what software version do they recommend for your system?  Are any versions of Microsoft or Xilinx SW incompatible or not supported?

 

3.  Xilinx -- ordinarily I would suggest updating to a more current version of ISE (which would also install a more current Jungo driver), but this might not work well with your NI LabView tools.

 

I would suggest asking the NI/LabView folks which combinations of LabView, ISE, Jungo driver, and Windows OS are recommended and supported to work together.  Every version of ISE (and corresponding Windows Jungo driver) from 10.x to 13.1 is available for download from the Xilinx site.  This gives you some flexibility on the Xilinx/ISE side.

 

-- Bob Elkind

SIGNATURE:
README for newbies is here: http://forums.xilinx.com/t5/New-Users-Forum/README-first-Help-for-new-users/td-p/219369

Summary:
1. Read the manual or user guide. Have you read the manual? Can you find the manual?
2. Search the forums (and search the web) for similar topics.
3. Do not post the same question on multiple forums.
4. Do not post a new topic or question on someone else's thread, start a new thread!
5. Students: Copying code is not the same as learning to design.
6 "It does not work" is not a question which can be answered. Provide useful details (with webpage, datasheet links, please).
7. You are not charged extra fees for comments in your code.
8. I am not paid for forum posts. If I write a good post, then I have been good for nothing.
Expert Contributor
bassman59
Posts: 6,212
Registered: ‎02-25-2008
0

Re: SPARTAN-3E usb cable driver


zyfeier wrote:

OS:Windows xp 

Hardware:SPARTAN-3E

Software:LabVIEW FPGA

 

The hardware can be identified , setup successfully, and the program passed compile. But when i run the programme, Windows prompts deathful error, which is that the windriver was outdated.


Saying "hardware: SPARTAN-3E" is too vague to be of use.

Is this FPGA installed on a National Instruments board? If yes, then call National Instruments and use the support resources you're paying for.

If it's not on an NI board, then it's doubtful that you can get LabView FPGA to work. 


----------------------------------------------------------------
Yes, I do this for a living.