UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

取消
显示结果 
搜索替代 
您的意思是: 
Adventurer
Adventurer
334 次查看
注册日期: ‎11-17-2017

linux-xlnx/drivers/gpu/drm下xilinx和xlnx这两个目录的区别

你好,

我在看github上的linux-xlnx内核驱动,发现linux-xlnx/drivers/gpu/drm下xilinx和xlnx都是描述drm的,他们之间有什么区别吗?为什么要分开?

0 项奖励
1 条回复1
Xilinx Employee
Xilinx Employee
261 次查看
注册日期: ‎03-27-2013

回复: linux-xlnx/drivers/gpu/drm下xilinx和xlnx这两个目录的区别

Hi chenyang1994,

 

从DRM KRS的driver描述来看:https://xilinx-wiki.atlassian.net/wiki/spaces/A/pages/18842520/Xilinx+DRM+KMS+driver

drivers/gpu/drm/xlnx是在2018.1版本下新开的Xilinx的DRM的新的driver架构,很多比较新的IP在2018.1以后转移到drivers/gpu/drm/xlnx架构下了

而drivers/gpu/drm/xilinx是最早的DRM driver的分支,很多老的IP使用的是这个分支

你会在一些比较新的IP的driver描述中看到类似如下,这个是MPSoC DP口的:

The below is for new driver (>= 2018.1)
The following config options should be enabled in order to build the DisplayPort driver
CONFIG_DRM_XLNX=y
CONFIG_DRM_XLNX_BRIDGE=y
CONFIG_DRM_XLNX_BRIDGE_DEBUG_FS=y
CONFIG_DRM_ZYNQMP_DPSUB=y

The below is for old driver (< 2018.1)
The following config options should be enabled in order to build the DisplayPort driver
CONFIG_DRM=y
CONFIG_DRM_XILINX=y
CONFIG_DRM_XILINX_DP=y
CONFIG_DRM_XILINX_DP_SUB=y

具体的可以参考Xilinx WIKI

Best Regards,
Jason
-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------
0 项奖励