UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

Reply

[Labtools 27-3165] End of startup status: LOW

Observer
Posts: 33
Registered: ‎03-31-2016

[Labtools 27-3165] End of startup status: LOW

I get the following error when i try to program the Artix-7 FPGA through the JTAG port using Platform Cable USB II on my board.  I try the same thing on a different board and it works without any issues.  What could be causing this error?  I have looked at all signals and voltages around the FPGA and all are identical between the two boards.  

 

I looked at another post with similar error message and it did not help.  I NEED HELP.......

 

set_property PROBES.FILE {} [lindex [get_hw_devices] 0]
set_property PROGRAM.FILE {C:/_Projects-FPGA/FTU100a2/FTU100a2.runs/impl_2/FTU100a2.bit} [lindex [get_hw_devices] 0]
program_hw_devices [lindex [get_hw_devices] 0]
ERROR: [Labtools 27-3165] End of startup status: LOW
program_hw_devices: Time (s): cpu = 00:00:06 ; elapsed = 00:00:06 . Memory (MB): peak = 1713.832 ; gain = 0.000
ERROR: [Common 17-39] 'program_hw_devices' failed due to earlier errors.

Xilinx Employee
Posts: 3,777
Registered: ‎04-16-2012

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com

 

Did you try reducing the cable speed?

Are you using the same bit file for programming in other boards?

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
Observer
Posts: 33
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Vinay, yes & yes.  What else should i look for?

Observer
Posts: 33
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Vinay, wrong answer from me.  How do i reduce the cable speed from the Hardware Manager in Vivado 2016.1?  If i remember it correctly, that option was available in Impact, but i don't see that in Hardware Manager.

Xilinx Employee
Posts: 3,777
Registered: ‎04-16-2012

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com

 

Follow below steps to reduce the cable speed:

 

1. Open HW Manager in Vivado GUI

2. Click on Open Target and select Open New Target

3. Click Next twice

4. In the "Hardware Targets" window, you will find the JTAG Clock Frequency.

5. Click on the drop-down and select the frequency.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
Observer
Posts: 33
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hello Vinay, it works without any issues with exactly the same setup and same .BIT file, if i change out my current board with an exactly similar board.  Only difference is that on the good board I get the "INFO: [Labtools 27-3164] End of startup status: HIGH" message instead of "ERROR: [Labtools 27-3165] End of startup status: LOW" message......

Observer
Posts: 33
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Tried out all clock speed options.  No change.  Still get the same error on End of Startup Status: LOW

Observer
Posts: 33
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi Vinay, any suggestions?

Xilinx Employee
Posts: 3,777
Registered: ‎04-16-2012

Re: [Labtools 27-3165] End of startup status: LOW

Hi jn.shah55@gmail.com

 

Share the status registers after programming failure.

 

Thanks,

Vinay

--------------------------------------------------------------------------------------------
Have you tried typing your question in Google? If not you should before posting. Also, MARK this is as an answer in case it helped resolve your query/issue.Give kudos to the post that helped you to find the solution.
Observer
Posts: 33
Registered: ‎03-31-2016

Re: [Labtools 27-3165] End of startup status: LOW

Hi Vinay, can you please tell me the steps to read back the status register after the failure?