UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Voyager
Voyager
2,011 Views
Registered: ‎10-31-2016

ZCU106: QSPI mode doesnt work

Jump to solution

Hello, 

 

I receive new hardware, where I did the initial test by booting it up in QSPI (mode set by switch) . This worked fine. 

 

Then I made my own .mcs file by adding

Capture.PNG

This way I add the bootloader 

Capture.PNG

 

This way I create the bootloader 

Capture.PNGCapture.PNG

 

After flashing the .mcs (QSDI mode according to switched ON OFF ON ON)file the program does not work i.e. the fpga is not able to initiate 

Capture.PNG

 

The same software if I flash without bootloader in jatag mode (pins configured) i.e first flash fpga file (.bit) and then flash PS software (.elf) then it works fine. Therefore I think there is a problem in bootloader file 

 

Please let me know if I miss some step for making bootloader file for board ZCU106.

 

Thank you 

Best regards 

 

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
Voyager
Voyager
1,754 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

process :

1. check jumper for pcie to enable 

2. make loop pcie PL implementation with xdma pcie IP

3. flash it into the flash memory with "qspi_dual_parallel" option or make boot image (fsbl + elf) and place in sd card 

4. run xilinx driver for pcie in ubuntu 14.0

https://www.xilinx.com/support/answers/65444.html

 

project (.tcl) and boot image in the attachment 

 

note : there is user ip to control LED (single_endto_diff_0), hence if that user IP is not loaded in the project no need to worrie :) 

 

how to place pcie:

1. include xdma pcie 

2. run auto setup 

(select maximum width, stream, 1 connection ) 

3. then connect out stream to in stream (loop back)

4. change the pins for pcie in IO planner (as it is not corectly done automatically)

5. assign the input pcie clock in clock planner to 100Mhz.

6. make .bit file 

7. export to sdk 

8. make fsbl

9. make boot image 

10. correct jumper setting in the board 

11. conent the board to pcie slot in pc with ubuntu 14.0 

12. check in the linux (lspci -v), as xilinx pcie 

13. run the xilinx driver 

 

All the best 

View solution in original post

0 Kudos
13 Replies
Community Manager
Community Manager
1,981 Views
Registered: ‎07-23-2012

Re: ZCU106: QSPI mode doesnt work

Jump to solution
Do you see any prints on serial terminal after you try to boot?

I would recommend you to follow the steps in https://www.xilinx.com/support/answers/68656.html to narrow down the issue.
-----------------------------------------------------------------------------------------------
Please mark the post as "Accept as solution" if the information provided answers your query/resolves your issue.

Give Kudos to a post which you think is helpful.
0 Kudos
Voyager
Voyager
1,938 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

here is what I see in 

 

Xilinx Zynq MP First StagýXilinx Zynq MP First Stage Boot Loader
Release 2018.1 þXilinx Zynq MP First SüXilinx Zynq MP First Sü

 

 

I even tried simple hello world but that also does not work.

 

Please see the flash log in the attachment.

 

I have this problem with both hardware (2 ZCu106)

 

 

 

 

0 Kudos
Voyager
Voyager
1,937 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

When I flash the file from the restore flash tutorial, then it works fine. but still, multiple restarts require to get to green lights. 

 

So I do not understand where is the problem.

0 Kudos
Voyager
Voyager
1,921 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

Ther is another msg states PMU is disabled hence some function won't work properly?


Will that created problem?

0 Kudos
Voyager
Voyager
1,917 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

I ran the bootloader in debug mode, there I found this error 

 

XFsbl_SpkVer: XFSBL_ERROR_SPK_SIGNATURE
Failure at boot header authentication

 

It seems there is a problem in FSBL generated from SDK for zynq ultrascale+ board ZCU106.

 

Please advice how to resolve it. 

 

thank you 

0 Kudos
Voyager
Voyager
1,908 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

here is the full log

0 Kudos
Xilinx Employee
Xilinx Employee
1,896 Views
Registered: ‎10-11-2011

Re: ZCU106: QSPI mode doesnt work

Jump to solution

I also see this error in your log "XFSBL_ERROR_IHT_CHECKSUM".

It appears the image is corrupted in the "image header table".

-------------------------------------------------------------------------
Don’t forget to reply, kudo, and accept as solution.
-------------------------------------------------------------------------
0 Kudos
Voyager
Voyager
1,876 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution
Here is the testing detail 
 
This is my model (with PCIe), in serial output, it just prints "HelloWorld" (PS side) and runs PCIe connection on PL
 
1.
a. QSPI flashing test: FAIL 
 
b. SD card run test: PASS 
 
Please see the log and .bif in the attachment.
 
2.
I am not using DDR, hence other tests are not applicable.
 
3.
Normal QSPI hello world test:  PASS
 
Please see the log
Looking forward to suggestion.
0 Kudos
Observer tom0501
Observer
1,626 Views
Registered: ‎05-11-2018

Re: ZCU106: QSPI mode doesnt work

Jump to solution

Hi! Now I work on ZCU106,and I add a DMA/Subsystem for pci express IPCore at PL. But wen I boot form SD card,kernel stop at [ 0.015866] bootconsole [cdns0] disabled.

As you say,your model also have pcie,and work well in SD card mode.Can you gave me a example design with PCIE?I hope it can help me to find out where is wrong,thanks!

0 Kudos
Voyager
Voyager
1,755 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

process :

1. check jumper for pcie to enable 

2. make loop pcie PL implementation with xdma pcie IP

3. flash it into the flash memory with "qspi_dual_parallel" option or make boot image (fsbl + elf) and place in sd card 

4. run xilinx driver for pcie in ubuntu 14.0

https://www.xilinx.com/support/answers/65444.html

 

project (.tcl) and boot image in the attachment 

 

note : there is user ip to control LED (single_endto_diff_0), hence if that user IP is not loaded in the project no need to worrie :) 

 

how to place pcie:

1. include xdma pcie 

2. run auto setup 

(select maximum width, stream, 1 connection ) 

3. then connect out stream to in stream (loop back)

4. change the pins for pcie in IO planner (as it is not corectly done automatically)

5. assign the input pcie clock in clock planner to 100Mhz.

6. make .bit file 

7. export to sdk 

8. make fsbl

9. make boot image 

10. correct jumper setting in the board 

11. conent the board to pcie slot in pc with ubuntu 14.0 

12. check in the linux (lspci -v), as xilinx pcie 

13. run the xilinx driver 

 

All the best 

View solution in original post

0 Kudos
Voyager
Voyager
1,568 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution

tcl

0 Kudos
Observer tom0501
Observer
1,559 Views
Registered: ‎05-11-2018

Re: ZCU106: QSPI mode doesnt work

Jump to solution

When I source the tcl file,I get error:

ERROR: [Vivado 12-172] File or Directory 'C:/Users/TOM/AppData/Roaming/Xilinx/Vivado/PCIeLoop.srcs/sources_1/bd/design_1/hdl/design_1_wrapper.vhd' does not exist

Can you tar the whole project?Thanks!

0 Kudos
Voyager
Voyager
1,552 Views
Registered: ‎10-31-2016

Re: ZCU106: QSPI mode doesnt work

Jump to solution
sorry , the site is not allowing me to upload as it is too big for it.

try following the steps which I mention before
let me know if boot.bin file which I shared it works for you
0 Kudos