UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Visitor mtalati.18
Visitor
310 Views
Registered: ‎06-14-2019

Zynq 7000 U-boot issue

Hello,

I'm using Zynq XQ7Z030-1RB484Q_1. As a QSPI flash I'm using S25FL512SAGMFI011. 

 

I'm able to program my Zynq using .bit file but not able to dump .mcs and .elf. I have followed 20K pull-up registets for QSPI mode configuration. My configuration is MIO2-0, MIO3-0, MIO4-0, MIO5-1, MIO6-0, MIO7-0, MIO8-0.

The power sequence for my card is shown attached here by. As well as PS_POR_B and PS_SRST also attached. 

 

Now I connected my customise board using JTAG to Vivado/SDK 2018.2. I tried to load .mcs and .elf file using SDK but it is showing UBoot error.

 

What to do to resolve this?

 

 

 

 

Slide5.PNG
Slide4.PNG
Slide3.PNG
Slide2.PNG
Slide1.PNG
0 Kudos
4 Replies
Moderator
Moderator
247 Views
Registered: ‎06-27-2017

Re: Zynq 7000 U-boot issue

Hi @mtalati.18 

 

Are you able to see the processor status using JTAG? May I know the error you are facing? console logs?

Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos
Moderator
Moderator
229 Views
Registered: ‎06-27-2017

Re: Zynq 7000 U-boot issue

Hi @mtalati.18 ,

 

Could you please refer AR65240 to refer further on Power on sequence for Zynq-7000 platform.

 

Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos
Visitor mtalati.18
Visitor
209 Views
Registered: ‎06-14-2019

Re: Zynq 7000 U-boot issue

Through JTAG, we are able to detect the processor. I have posted an image of the console.

IMG-20190624-WA0004.jpg
0 Kudos
Moderator
Moderator
198 Views
Registered: ‎06-27-2017

Re: Zynq 7000 U-boot issue

Please refer the AR suggested for power sequence. It is observed from your images that they POR_B and PS reset signals are not clean. Could you please check once?

Best Regards
Kranthi
--------------------------
Don't forget to reply, kudo, and accept as solution.
0 Kudos