UPGRADE YOUR BROWSER

We have detected your current browser version is not the latest one. Xilinx.com uses the latest web technologies to bring you the best online experience possible. Please upgrade to a Xilinx.com supported browser:Chrome, Firefox, Internet Explorer 11, Safari. Thank you!

cancel
Showing results for 
Search instead for 
Did you mean: 
Highlighted
Contributor
Contributor
293 Views
Registered: ‎06-04-2019

Hardware CoSimulation using JTAG on ZCU111 not giving expected results

Jump to solution

Hello all,

I am struggling to debug a simple model I have. I designed a simple model using Sys Gen 2018.3. I attached a screenshot and also the model.

hwcosim_model1.PNG

System generator token settings,

tokensettings.PNG

I have given fpga clock as 100MHz which is available for my board zcu111 (Xilinx Ultrascale+ RFSoC) xczu28dr. I generated Hardware CoSimulation library and tested along side the simulink model. The results were not the same.

In the 'multiplierEx hwcosim' block, checking 'has combinational path' gives output as 0 and unchecking the same gives 0.0007569.

Additional observation, the post sysnthesis timing summary has lot of negative slacks with respect to jtag top module paths

timingerrormultex.PNG

I also found from the block diagram, that a clock of 50MHz is generated from 300MHz clock using clocking wizard. I do not understand why sys gen generated this when I actually gave a clock of 100MHz (10ns fpga clock period) in the sys gen token.

Please help me get through this. It is a simple example and I am struggling for days. Any help would be appreciated.!

Thanks,
Bhavanithya Thiraviaraja
0 Kudos
1 Solution

Accepted Solutions
Xilinx Employee
Xilinx Employee
214 Views
Registered: ‎12-14-2017

Re: Hardware CoSimulation using JTAG not giving expected results

Jump to solution

Hi,

ZCU111 board is not supported in sysgen for HWcosim, but some how the option was enabled for the board in 2018.3. In 2019.1 vivado release, you will see the correct list of boards that sysgen supports for Hwcosimulation. Please use some other board to get rid of the issue.

Hope this helps

0 Kudos
2 Replies
Xilinx Employee
Xilinx Employee
215 Views
Registered: ‎12-14-2017

Re: Hardware CoSimulation using JTAG not giving expected results

Jump to solution

Hi,

ZCU111 board is not supported in sysgen for HWcosim, but some how the option was enabled for the board in 2018.3. In 2019.1 vivado release, you will see the correct list of boards that sysgen supports for Hwcosimulation. Please use some other board to get rid of the issue.

Hope this helps

0 Kudos
Contributor
Contributor
207 Views
Registered: ‎06-04-2019

Re: Hardware CoSimulation using JTAG not giving expected results

Jump to solution

Hopefully it is fixed soon. It is misleading. Thank you for the information.! 

Thanks,
Bhavanithya Thiraviaraja
0 Kudos