cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
dmittiga
Observer
Observer
3,069 Views
Registered: ‎03-08-2019

MATLAB support for 2019.1 is misleading

Jump to solution

When I look through the 2019.1 user guide (https://www.xilinx.com/support/documentation/sw_manuals/xilinx2019_1/ug973-vivado-release-notes-install-license.pdf), table 2 mentions MATLAB 2017a, 2017b, or 2018a as the only compatible MATLAB versions. However, when I run the MATLAB Configurator for 2019.1, I find my 2017b version manually (not shown in the list by default), I get the error "MATLAB version is not supported by System Generator Vivado 2019.1".

So what versions are supported? The User Guide for 2019.1 appears to be incorrect and the https://www.xilinx.com/support/answers/55830.html page has not been updated for 2019.1 either.

1 Solution

Accepted Solutions
vkanchan
Xilinx Employee
Xilinx Employee
3,028 Views
Registered: ‎09-18-2018

Hi @dmittiga ,

This is a typo in the document you have referrred. 

Sysgen officially supports current year + last year version of Matlab.

So 2019.1 should support R2018a, R2018b and R2019a.

 

The documentation which you have pointed needs to be updated. Please check the below link for correct details.

https://www.xilinx.com/products/design-tools/vivado/vivado-whats-new.html#2019_1

That is why 2017b does not appear on the MATLAB configurator.

View solution in original post

7 Replies
vkanchan
Xilinx Employee
Xilinx Employee
3,029 Views
Registered: ‎09-18-2018

Hi @dmittiga ,

This is a typo in the document you have referrred. 

Sysgen officially supports current year + last year version of Matlab.

So 2019.1 should support R2018a, R2018b and R2019a.

 

The documentation which you have pointed needs to be updated. Please check the below link for correct details.

https://www.xilinx.com/products/design-tools/vivado/vivado-whats-new.html#2019_1

That is why 2017b does not appear on the MATLAB configurator.

View solution in original post

2,844 Views
Registered: ‎11-20-2018

In the link you gave, It is mentioned as "Supported MATLAB Versions:R2018a, R2018b and R2019". It doesn't differentiate between R2019a and R2019b, so can you confirm is Matlab R2019b also supported by VIvado 2019.1?

0 Kudos
2,201 Views
Registered: ‎01-01-2020

Capture.PNG

sir, My system Generator 2019.2 configurator  is showing this message as you can see they no supported versions of matlab 2016a/b and 2017a/b found so is it misleading ? 

0 Kudos
neol_1998
Observer
Observer
2,038 Views
Registered: ‎02-27-2019

You have to specify path to matlab executable file in your environment variables. Go to control panel and select environment variables and select path and add your path till matlab.exe. For example

C:\users\matlab\bin\matlab.exe

Now launch matlab configuration for the system generator and click on find matlab and select matlab installation folder.It will be configured

I have vivado 2019.1 and matlab of 2019a.

If you have still doubt then please comment again and if this solved your problem then give kudos. 

0 Kudos
tsillanp
Adventurer
Adventurer
1,394 Views
Registered: ‎10-14-2013

Please Xilinx, fix the "release notes" & "What's new" -web-page. Both are currently, and still, wrong.

Webpage:
"Supported MATLAB Versions:R2018a, R2018b and R2019"

Release Notes:
"The MathWorks MATLAB®
and Simulink® (R2017a,
R2017b, and R2018a)"

0 Kudos
942 Views
Registered: ‎11-30-2019

Ping @vkanchan , it's not very good customer practice to leave erroneous information in your official documents.

0 Kudos
danny1981
Observer
Observer
664 Views
Registered: ‎05-16-2014

>>It doesn't differentiate between R2019a and R2019b, so can you confirm is Matlab R2019b also supported by VIvado 2019.1?

I also tried associating MATLAB 2017a with SysGen 2019.1. The resulting MATLAB error msg stated that only 2018 a/b and 2019a were supported.

0 Kudos