cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
Highlighted
25,197 Views
Registered: ‎03-05-2009

Problem with generation on Linux

Hi,

I've just install Matlab R2009a and System Generator 11.2 on Fedora.

I've got a problem with a small test project (gateway in and out with a inverter between).
When I generate the HDL netlist with the System Generator token, an error occure.

Here is the sysgen error report:


--------------------------------- Version Log ----------------------------------
Version                                 Path
System Generator 11.2.1866              /opt/Xilinx/11.1/DSP_Tools/lin/sysgen
AccelDSP 11.2.1866                      /opt/Xilinx/11.1/DSP_Tools/lin/AccelDSP
Matlab 7.8.0.347 (R2009a)               /opt/Matlab
ISE 11.2.i                              /opt/Xilinx/11.1/ISE
--------------------------------------------------------------------------------
Summary of Errors:
Error 0001: Program "gcc" returned non-zero status (1).

     Block: 'test/Inverter'
--------------------------------------------------------------------------------

Error 0001:

Reported by:
  'test/Inverter'

Details:
Program "gcc" returned non-zero status (1).

Error occurred during "Simulation Initialization".

--------------------------------------------------------------------------------


Please help.

 
Thanks
0 Kudos
1 Reply
Highlighted
Visitor
Visitor
25,119 Views
Registered: ‎02-11-2009

Hi Laurent,

 

  I have installed ISE Design suite on my Ubuntu 9.04 64-bits with Matlab 2009a and had run into some similar problems too (see http://forums.xilinx.com/xlnx/board/message?board.id=DSPTOOL&thread.id=1837 ). I was able to simulate some simple blocks but the simulation of more complex blocks or trying to generate a bitstream results in errors. I have seen that many libraries were missing and I was able to resolve all the dependencies, but the errors are still there. If you have better luck, please, tell me.

 

  Regards,

  Cristiano

0 Kudos