cancel
Showing results for 
Show  only  | Search instead for 
Did you mean: 
MichaelK
Contributor
Contributor
679 Views
Registered: ‎06-25-2020

DPU TRP 2019.2 camera problems

Jump to solution

Hello!

I'm trying to use the DPU TRD 1.1 from the Vitis AI GitHub page. Building it through the Vitis-Flow worked well. But i have trouble using the example applications. The resnet50 and other examples that are work with files are working well, but examples that use the camera don't.
When i start the face recognition I see a view seconds of video (very low fps). After that the image freezes and it shows "select timeout" in the commandline. I activated trace in the uvcvideo drivers parameters and dmesg shows lots of "uvcvideo: Dropping payload (out of sync)." errors. Supposed fixes I found on the internet like quirks/nodrop/timeout-parameter for the uvcvideo-driver didn't work.
Is this a problem with the TRD or my hardware? I'm working with a ZCU102 Rev 1.0 and a LI-USB30-AR023ZWDR camera.

0 Kudos
1 Solution

Accepted Solutions
MichaelK
Contributor
Contributor
513 Views
Registered: ‎06-25-2020

Setting the QoS-Parameter:
 

/sbin/devmem 0xFD370008 w 0x3

/sbin/devmem 0xFD37001C w 0x3

/sbin/devmem 0xFD380008 w 0x3

/sbin/devmem 0xFD38001C w 0x3

/sbin/devmem 0xFD390008 w 0x3

/sbin/devmem 0xFD39001C w 0x3

/sbin/devmem 0xFD3A0008 w 0x3

/sbin/devmem 0xFD3A001C w 0x3

/sbin/devmem 0xFD3B0008 w 0x3

/sbin/devmem 0xFD3B001C w 0x3

/sbin/devmem 0xFD380004 w 0xF

/sbin/devmem 0xFD390004 w 0xF

/sbin/devmem 0xFD3A0004 w 0xF

/sbin/devmem 0xFD3B0004 w 0xF

/sbin/devmem 0xFD380018 w 0xF

/sbin/devmem 0xFD390018 w 0xF

/sbin/devmem 0xFD3A0018 w 0xF

/sbin/devmem 0xFD3B0018 w 0xF

 

 

helped.

View solution in original post

0 Kudos
6 Replies
jasonwu
Moderator
Moderator
625 Views
Registered: ‎03-27-2013

Hi @MichaelK ,

 

Are you using SSH X11 forward to get the video displayed?

This would be with heavy CPU loading, maybe you could try with DP port as video output port.

And TRD 2020.1 is released now you could also try with that.

Best Regards,
Jason
-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------
0 Kudos
MichaelK
Contributor
Contributor
615 Views
Registered: ‎06-25-2020

Hey @jasonwu 

thank you for your answer.

I'm using the DP as output for the video and I don't think the CPU usage is the problem, because it satys at ~30%.
I can't really use the 2020.1 version. The rest of my project is based on 2019.2 tools.

Best regards,
Michael

0 Kudos
jasonwu
Moderator
Moderator
582 Views
Registered: ‎03-27-2013

Hi @MichaelK ,

 

Thanks for your update. So what is the video format and dimension configuration for this USB 3 camera?

Best Regards,
Jason
-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------
0 Kudos
MichaelK
Contributor
Contributor
572 Views
Registered: ‎06-25-2020

Hey @jasonwu 

The dimensions are 1920x1080 and the format is YUV 4:2:2 at 30FPS.

Is it possible, that the USB 3.0 is only connected to the PL and the PS only gets USB 2.0?

0 Kudos
jasonwu
Moderator
Moderator
536 Views
Registered: ‎03-27-2013

Hi @MichaelK ,

 

Even if running at USB 2.0 it should work.

I tried with a USB 2.0 camera(I only have USB 2.0 on my side) with the 2020.1 released ZCU102 image. And it can work(with hogh latency  and low fresh rate).

You can find log information to get the details of your USB camera status like the one on my sider:

[    4.892238] usb 1-1.4: new high-speed USB device number 5 using xhci-hcd
[    5.106203] usb 1-1.4: New USB device found, idVendor=0c45, idProduct=6366, bcdDevice= 1.00
[    5.106211] usb 1-1.4: New USB device strings: Mfr=2, Product=1, SerialNumber=3
[    5.106215] usb 1-1.4: Product: USB 2.0 Camera
[    5.106220] usb 1-1.4: Manufacturer: Sonix Technology Co., Ltd.
[    5.106223] usb 1-1.4: SerialNumber: SN0001

During the test the USB camera is set as below:

root@xilinx-zcu102-2020_1:~# v4l2-ctl -d /dev/video0 --get-fmt-video
Format Video Capture:
        Width/Height      : 1920/1080
        Pixel Format      : 'YUYV' (YUYV 4:2:2)
        Field             : None
        Bytes per Line    : 3840
        Size Image        : 4147200
        Colorspace        : sRGB
        Transfer Function : Default (maps to sRGB)
        YCbCr/HSV Encoding: Default (maps to ITU-R 601)
        Quantization      : Default (maps to Limited Range)
        Flags             :

I also attached the boot and test log here.

Maybe you can try with the latest image and compare the log if the issue still occurs.

Best Regards,
Jason
-----------------------------------------------------------------------------------------------
Please mark the Answer as "Accept as solution" if the information provided is helpful.

Give Kudos to a post which you think is helpful and reply oriented.
-----------------------------------------------------------------------------------------------
MichaelK
Contributor
Contributor
514 Views
Registered: ‎06-25-2020

Setting the QoS-Parameter:
 

/sbin/devmem 0xFD370008 w 0x3

/sbin/devmem 0xFD37001C w 0x3

/sbin/devmem 0xFD380008 w 0x3

/sbin/devmem 0xFD38001C w 0x3

/sbin/devmem 0xFD390008 w 0x3

/sbin/devmem 0xFD39001C w 0x3

/sbin/devmem 0xFD3A0008 w 0x3

/sbin/devmem 0xFD3A001C w 0x3

/sbin/devmem 0xFD3B0008 w 0x3

/sbin/devmem 0xFD3B001C w 0x3

/sbin/devmem 0xFD380004 w 0xF

/sbin/devmem 0xFD390004 w 0xF

/sbin/devmem 0xFD3A0004 w 0xF

/sbin/devmem 0xFD3B0004 w 0xF

/sbin/devmem 0xFD380018 w 0xF

/sbin/devmem 0xFD390018 w 0xF

/sbin/devmem 0xFD3A0018 w 0xF

/sbin/devmem 0xFD3B0018 w 0xF

 

 

helped.

View solution in original post

0 Kudos